Arduino Yun - Configuration - SSID key field missing

Hej folks,

when I tried configuring several Arduino Yun last week I encountered following strange problems.
Firstly on the configuration page there were no WiFi networks available to choose from, also after a refresh. Secondly when I entered an SSID manually and I chose a security standard the field to enter a password was simply not showing up. Also luci, the advanced configuartion panel was not available. Attached some screenshots showing those issues. I tried it in Chrome, Mozilla and Internet Explorer and with several brand new Arduino Yuns with and without updated software. Finally I managed to enter the password by using the dynamic CSS editing feature in Chrome, removing the “hidden” class from the password input field manually. I am now just curious why these problems occured.

Thanky for your replies already in advance.
Best regards,
Dobs

System:
Dell Latitude E6430 - Windows 7 Pro SP1 64bit


The WiFi Networks not showing up in the list.


The missing SSID key/password field


Error on opening luci interface

List SSIDs in terminal:

iwlist wlan0 scan | grep ESSID
ESSID:"TG1672G52"
ESSID:"TG1672GC2"
ESSID:"TG1672G72"
ESSID:"DG1670AA2"
ESSID:"TG1672G92"
...

Access Yun from browser via directly, not via http proxy.

Test it when turn off Dell Latitude E6430 - Windows 7 Pro SP1 64bit's firewall.