Arduino Yun issue after system upgrade

I got the board up and running. I configured the Wifi connection via and was able to connect to it from the Arduino IDE (via network connection in Port menu). None of the sketches I tried to upload worked. I received the following error when uploading a sketch :

arduino avrdude: AVR device not responding

I decided to upgrade the WRT firmware on the Arduino. I followed this guide : https://www.arduino.cc/en/Tutorial/YunSysupgrade

I copied the firmware file to a USB stick. Connected to the Arduino via SSH and received the same output as on the tutorial :

run-sysupgrade /mnt/sda1/openwrt-ar71xx-generic-yun-squashfs-sysupgrade.bin
Sending TERM to remaining processes … uhttpd dbus-daemon dnsmasq avahi-daemon thd ntpd uSDaemon sleep syslogd klogd hotplug2 procd ubusd netifd
Sending KILL to remaining processes …
Switching to ramdisk…
Performing system upgrade…
Unlocking firmware …
Writing from to firmware …
Upgrade completed
Rebooting system…

On reboot I was no longer able to connect to the Arduino. The LAN lights are flashing but I could not detect any IP request. I tried to reset using the WLAN reset button and holding for 30s but I didn’t see any LED flashes.

I connected the Yun via USB to a PC and MAC on both I am able to see the device, I can upload sketches and they are working (Blink) but I am still not able to get the WLAN reset (see arduino hot spot). If am able to upload the YunSerialTerminal but when I open the monitor I am not seeing any output. I have changed the baudrate to match the one in the script (115200) and I have changed the line ending to “New Line”. Nothing is showing up in the monitor output.

Not sure how to proceed at this time, any help would be greatly appreciated.