Arduino Yun network configuration

Hello,

I use Arduino Yun as AP, with some custom configuration, which is custom SSID, static IP adress and subnet mask, DHCP server etc.

After configuring it manually on the web access page and saving configuration it seems to be working fine as long as the power is plugged in.

The problem is with power of and on again, Arduino is reverting the network configuration to the default (ARDUINO-xxxxxxxxxx SSID, IP=192.168.240.1).

How can I keep the configuration even if i power the unit off and plug the power out?

I power the Arduino using 5V in power (not the USB connector).

have anyone encountered such a problem?

Arduino Yun Power:

It is recommended to power the board via the micro-USB connection with 5VDC.

If you are powering the board though the Vin pin, you must supply a regulated 5VDC. There is no on-board voltage regulator for higher voltages, which will damage the board.

The Yún is also compatible with PoE power supply but in order to use this feature you need to mount a PoE module on the board or buy a preassembled board.

Test it with micro-USB connection.

The voltage I supply is regulated 5VDC to Vin pin.

The problem with Yun reseting the wifi configuration happens in both cases of using USB port and 5V Vin. So i assume this is not a power issue.

Can you advise on the WIFI reset issue?

nano /etc/rc.local
#wifi-live-or-reset

sonnyyu:

nano /etc/rc.local
#wifi-live-or-reset

This code will generate the WIFI reset.
My problem is that my custom configuration is lost after power down of the Arduino, and this I want to prevent.

Can you help?

I think I need to explain my problem better :slight_smile:

In my application, the Yun board is used as wireless AP, with computer connected to the wired LAN.
The AP has static IP address, and it is responcible for giving IP to any wirless clients, and connect them to the network.

This is my network file configuration:

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'
option proto 'static'
option netmask '255.255.255.0'
option ipaddr '192.168.1.253'
option type 'bridge'
option _orig_ifname 'wlan0'
option _orig_bridge 'true'
option ifname 'eth1'

config interface 'wan'
option ifname 'eth1'
option _orig_ifname 'eth1'
option _orig_bridge 'false'
option proto 'none'

And this is my WIFI file configuration

config wifi-device 'radio0'
option type 'mac80211'
option channel '11'
option hwmode '11ng'
option path 'platform/ar933x_wmac'
option htmode 'HT20'
list ht_capab 'SHORT-GI-20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'
option disabled '0'
option txpower '16'
option country 'US'

config wifi-iface
option device 'radio0'
option mode 'ap'
option ssid 'XXX001'
option network 'lan'
option encryption 'psk2+ccmp'
option key '01234567'
option hidden '1'

This configuration is actually working fine. Ocasionally, when I plug in the Arduino Yun, after some time being shut down, the configuration goes back to default (SSID=ARDUINO YUNmac......, and IP=192.168.240.1).
I would like to know the reason for such configuration reset and any way to prevent this.

Thanks,

wifi-live-or-reset

But, if something goes wrong and the Yún is not able to connect to the configured Wifi network within 60 seconds, by default it resets the network configuration (loosing your configuration) and it enters again in the Access Point mode(192.168.240.1).

comment out it will stop it happening.

#wifi-live-or-reset

Thanks, I've done this, and checking if the configuration will hold.

Thank you.