Arduino Yun: SD Card doesnt work

Hello,

first, english isnt my native language, but i hope to get more feedback then language specific threads.

Im trying a webserver on the new Arduino Yun.
I checked out this tutorial http://scuola.arduino.cc/courses/lessons/view/b4EoRkV. I configured the linino Webinterface and also created a “www” folder (incl. index.htm) in the actually sketch folder.

But when i stated uploading everything, the arduino told me that something with my sd card isnt correct.

Sketch uses 21.030 bytes (73%) of program storage space. Maximum is 28.672 bytes.
Global variables use 642 bytes (25%) of dynamic memory, leaving 1.918 bytes for local variables. Maximum is 2.560 bytes.
Warnung: Problem accessing board folder /www/sd

In the webinterface configuration i can found this sd card at mounts. 16Gb from 16Gb are free.

This sd card works well with the Arduino ethernet shield, but i cant get it work on my Yun.

Thank You

hey,

got my arduino yun today and had the same problem. i managed to solve it as follows.

  • make sure project name and folder name are the same
  • add a folder "www" to your project folder and add the documents u want to copy (html, pictures, txt,...)
  • format the µSD card to FAT ether FAT, FAT16 or FAT32
  • Manually add a folder "arduino" and add a sub folder "www" on the µSD card.
  • put the card in the arduino and try download again.

open your browser and try http://xxx.xxx.xxx.xxx/sd/Projectname/ ==> where x's are the IP address of your arduino's WiFi and Projectname is obvious the same as loaded project.

hope this helps.

Hello,

it looks like I am seeing the same behaviour as sschultewolter -- after some waiting during sketch upload I get the message "Warnung: Problem accessing board folder /www/sd". I have tried jensdewispelaere's advice, however no success :frowning:

Any other advice? I guess it is something rather stupid or obvious that is wrong. Any help is appreciated.

What I have tried already seems all to run fine:

= Using two different brand name (Sandisk) micro SD cards (one 2GB, one 4GB)
= Freshly formatted as FAT in a Mac and in a digital camera
= Added the /arduino/www folders from my Mac and filled them with some test files
= Checked the folders from the Yun using SSH, everything can be read
= Added the /mnt/sda1/arduino/www folders on the Yun using SSH (obviously removing them before)
= Removed all external hardware like LEDs and Sensors

My Yun is connected to my home wifi, its web interface can be accessed reliably through "http://arduino.local"

did u put the www folder with content in same folder as your project?
did u upload trough Wifi/eth. because usb loading doesnt copy files to arduino sd card.

Hi,

I have the same problem as the OP.

The SD card is formatted as FAT32. This is what mount spits out:
/dev/sda1 on /mnt/sda1 type vfat (rw,sync,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)

I have created /mnt/sda1/arduino/www/
root@YuFly:/mnt/sda1/arduino/www# pwd
/mnt/sda1/arduino/www

Permissions look like this:
root@YuFly:/mnt/sda1# ls -la
drwxr-xr-x 3 root root 32768 Feb 15 16:45 .
drwxr-xr-x 1 root root 0 Feb 15 16:07 ..
drwxr-xr-x 3 root root 32768 Feb 15 16:46 arduino

When I upload a sketch per Wifi no problem. If I add the www/ folder in the project directory I get the error: problem accessing board folder /www/sd

Arduino version 1.5.5

Thanks for your help!

bump - sorry, but no one got an idea what else I can try? I'm pretty stuck.

Thanks!

Same here, pretty shabby that no official documentation is available how to get the Yun to work with SD cards :0

Or if it is then make it easier to find!

Well, the SD card in itself works. I can ssh to the Yun and see the card mounted and I can create files on it.
What I can not is change permissions but since everything runs as root anyway this should not be a problem.

Solved it:
http://forum.arduino.cc/index.php?topic=218640.msg1596383#msg1596383

Try this command on the terminal (SSH) before uploading the code.
This worked for me

ln -s /mnt/sda1 /www/sd

I do not know if it is the same problem that the others in this thread are experiencing, but I tried to benchmark the writing speed of different SD cards. Being spoiled with Arduino resetting itself after uploading sketches, and generally being able to switch Sd cards on the go, I switched SD cards without resetting, with the result that no files were written.

Thus when having problems writing SD cards one thing to try is to Reset the Yun, i.e. press the reset button by the row of LEDs. Resetting the 32u4 part is not enough.

I guess the more competent Linux users would mount/umount the drives, but resetting works fine for me!

I have tried every possible solution I can find on these forums and google. But still I'm not able to browse the files on the SD-card or upload a sketch with files in it.

I have no problem logging in with SSH and create/rename folders on the SD-card.

Using latest 1.3 with basic setup and no other hardware connected.
I have tried different cards, USB drives and OS X/Windows systems...

Any ideas?

I guess FileIO.h or Bridge.begin() error
I joined LED But No action

#include <FileIO.h>
void setup() {
pinMode(13, OUTPUT);
Bridge.begin();
Serial.begin(19200);
FileSystem.begin();
while(!Serial);
}
void loop () {
digitalWrite(13, HIGH);
delay(500);
digitalWrite(13, LOW);
delay(500);
const char filenamepath = “/mnt/sda1/data.txt”;