Arduino Yun + Seeedstudio CAN-BUS Shield V1.0

Hello at all,

I'm new to the forum and a neewbe to arduino as well. A few months ago I bought the Seeedstudio CAN-BUS shield V1.0 (03/06/2013) and wanted to get it work with my Arduino Yun. I'm on a project to communicate with Seatalk (Protocol from Raymarin and nearby the same like NMEA2000). The Baudrate of Seatalk is, as I know, 250 kbps. I tried a lot, but without any success.

So I had a look at the different recommendations on the net and at the Wiki ( http://www.seeedstudio.com/wiki/CAN-BUS_Shield ), too. I tried as well different libraries e.g. CAN Analyzer and the SAE J1939 Project.

I also had a look to this topic LINK but it doesn't really suit to my pblm.

I tested the Pin 9 and 10 (I know for my version I've to use Pin 10), I soldered even CS to Pin 9 but also without any success.

So actually I'm trying to debug my code and the code of the functions to find out whats the matter. After putting mcp_can.cpp into the DEBUG_MODE I found out that the system doesn't go any further than "MCP_CAN::mcp2515_init". On the COM Port I can read the message "Enter setting mode fall".

So atm I don't know what to do.

Is the problem due to the Arduino Yun? Or due to the CAN-BUS Shield?

BTW, for my project I bought the Grove Base shield with some sensors which works (only one shield at a moment) really fine.

Hope you can help me solving this issue.

Regards

Eckie

No-one can help?