Arduino Yun strange failure

Alright I’ve never encountered this type of a scenario before and I’m hoping someone could shed some light on what is going on.

I have 3 prototypes that are identical, I uploaded a sketch to one of the prototypes which included a RFMB12 library and some test code for the radio module. Since uploading that code I have experienced the following :

  1. The Yun is running the sketch I uploaded but in slow motion. Sensors still work, LED’s still change states, but the code is running extremely slow.

  2. The RX LED is stuck on.

  3. When I connect the Yun to the PC the device manager gives me a “Device Descriptor Request Failed” error. However If I connect another of the prototype setups it recognizes the Yun just fine.

I’ve tried the usual reset mamba, updated to 1.5.8, tried re-installing drivers, but no dice. I’ve had “device descriptor” errors in the past that i fixed by re-installing drivers, but the slow-motion and RX light are something I haven’t seen before.

Thanks for any help in advance. I posted in this section because I figure it’s either a driver or software issue.

It seems that there are problems with the bootloader running on the Atmega side and fuses configuration. First upgrade the Linux side following this guide http://arduino.cc/en/Tutorial/YunSysupgrade . Then upload the Blink example sketch via WiFi. Uploading a sketch via Wifi resets the bootloader and fuses so this should fix your problems.