Arduino Yun/Ubuntu 14.04/fstream: No such file or directory

Hello everybody,

I am trying to upload this code to my Arduino Yun in Ubuntu and I keep getting this error:

Arduino: 1.5.8 (Linux), Board: “Arduino Yún”

Build options changed, rebuilding all
Using library FileIO in folder: /home/djloulou/Arduino/libraries/FileIO (legacy)

/home/djloulou/arduino-1.5.8/hardware/tools/avr/bin/avr-g++ -c -g -Os -w -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -MMD -mmcu=atmega32u4 -DF_CPU=16000000L -DARDUINO=158 -DARDUINO_AVR_YUN -DARDUINO_ARCH_AVR -DUSB_VID=0x2341 -DUSB_PID=0x8041 -DUSB_MANUFACTURER= -DUSB_PRODUCT=“Arduino Yun” -I/home/djloulou/arduino-1.5.8/hardware/arduino/avr/cores/arduino -I/home/djloulou/arduino-1.5.8/hardware/arduino/avr/variants/yun -I/home/djloulou/Arduino/libraries/FileIO /tmp/build8511320611227460765.tmp/sketch_dec01a.cpp -o /tmp/build8511320611227460765.tmp/sketch_dec01a.cpp.o
In file included from yun_datalogger.ino:31:0:
/home/djloulou/Arduino/libraries/FileIO/FileIO.h:12:19: fatal error: fstream: No such file or directory
#include
^
compilation terminated.
Error compiling.

I then tried in Windows and it works fine.

So I guess it’s an ubuntu problem, I think I should install a new package or something but if someone could guide me throught this I would really appreciate it because I m really new in Ubuntu.

ionchoco:
I then tried in Windows and it works fine.

Very distressing - it’s usually the other way round.

But you have not posted your code so I can’t try it.

…R

Oh sorry!

I was supposed to put the hyperlink here

Anyone plz?

still can’t make it work

Sorry, I did not see your earlier reply and I don't know the answer.

I will ask the Moderator to move your Thread to the Yun section

...R

Quick dirty fix, ( which I normally does) , ghost back fresh copy of Ubuntu and re-install fresh copy of Arduino IDE.