Arduino Yun Wifi Hotspot with Ralink RT5370

Hi,
I've just bought a wifi dongle with Ralink RT5370 Chipset.
The installation of the related packages was fine and Linino recognized the new dongle.
opkg install kmod-rt2800-lib kmod-rt2800-usb kmod-rt2x00-lib kmod-rt2x00-usb

I tried to disable the internal WIFI and enable the new one via Luci Interface and modifying /etc/config/wireless but I didn't solved the problem. My pc tries to connect to the wifi (new dongle interface) but gets no IP. I think it's Linino's DHCP server problem . Have you got some tips? Thanks

rockeronline00:
::::SNIP::::

I tried to disable the internal WIFI and enable the new one via Luci Interface and modifying /etc/config/wireless but I didn't solved the problem. My pc tries to connect to the wifi (new dongle interface) but gets no IP. I think it's Linino's DHCP server problem . Have you got some tips? Thanks

@rockeronline00,
Yes. Why are you turning off a perfectly good wifi?

Jesse

Because I'm building an Arduino Yun-based quadcopter and Arduino's Wifi sucks... only 5 meters -.-

rockeronline00:
Because I'm building an Arduino Yun-based quadcopter and Arduino's Wifi sucks... only 5 meters -.-

@rockeronline00,
then add an antenna and turn up the power.

Google arudino yun attenna

Connecting external antenna to Arduino Yun

OpenWrt Wireless FAQ
http://wiki.openwrt.org/doc/faq/faq.wireless

Jesse

Hi Jesse,
thanks but I have already read those posts on external antenna, and as you could see, there's no possibility.

So as I posted above, I'm trying with a dongle Wifi since OpenWrt recognizes it.
My problems come from OpenWrt's DHCP server.. When I enable the dongle (and disable the internal antenna) DHCP doesn't work anymore .
So my PC finds the new network (of the new dongle wifi) but can't connect due to this problem

Do it at your own risk! ( back up your own data)

/usr/bin/reset-to-factory-anyway
opkg update  
opkg install kmod-rt2800-lib kmod-rt2800-usb kmod-rt2x00-lib kmod-rt2x00-usb
cd /etc/modules.d
mv 24-rt2x00-lib 22-rt2x00-lib
mv 26-rt2x00-usb 23-rt2x00-usb
mv 27-rt2800-lib 24-rt2800-lib
mv 28-rt2800-usb 25-rt2800-usb

reboot Yun

mv /etc/config/wireless /var  
wifi detect > /etc/config/wireless
nano /etc/config/wireless
config wifi-device  radio1
...
option disabled 0

reboot Yun then test

Tenda W311MI (Ralink RT5370 base USB Adapter)

http://www.amazon.com/Tenda-W311M-150Mbps-Wireless-Adapter/dp/B006GCYAOS

$13.61 2 days free shipping

Wow it works !!! You can't imagine how I'm happy !!! thank you so much !!

it does not seem to work anymore. The arduino freezes as soon as the wifi dongle is enabled. Did anyone managed to make it work?

/usr/bin/reset-to-factory-anyway
reboot

is very important. and follow rest step carefully.

Disable internal radio might help.

nano /etc/config/wireless
config wifi-device  radio0
...
option disabled 1

clynamen:
it does not seem to work anymore. The arduino freezes as soon as the wifi dongle is enabled. Did anyone managed to make it work?

@clynamen,
the person with original post did. And several other people also.

Make sure to follow SonnyYu’s instructions. Make sure the dongle is on tightly. A loose dongle will cause a weak electrical link and the software will stall and freeze.

Jesse

I actually didn't realize the post was so recent, and I though that an update caused a break. Thanks for your information, I'll retry again

rockeronline00:
thanks but I have already read those posts on external antenna, and as you could see, there’s no possibility.

Actually, although a little kludgey, a low cost solution has been found: http://forum.arduino.cc/index.php?topic=188976.msg2214560#msg2214560