Arduino Yun wont factory restore, memory use is always full

I have an arduino yun and I have tried holding down the wlan reset for more than 30 seconds, it does not factory restore the device.

My file system looks like the following after the restore the root is 100% used. I have tried running /usr/bin/reset-to-factory-anyway && reboot after ssh in and it still doesn't change. I was trying to expand my memory with this but it gave me a memory to small warning need one more mb. the micro sd card I was using was 32gb

Not sure what to do here

I upgraded my yun using this

Here is my system

Router Name Arduino
Router Model Arduino Yun
Firmware Version OpenWRTYun Attitude Adjustment 1 / LuCI 0.11 Branch (0.11+svn10537)
Kernel Version 3.3.8
Local Time Thu Sep 8 15:58:52 2011
Uptime 0h 15m 25s
Load Average 0.10, 0.10, 0.10

I have also tried uninstall packages in opkg that were old like spacebrew and python and didn't change anything. I thought factory restore should delete those packages. I know the firmware upate worked becasue my advanced config in arduino.local changed really stuck here.

I used the sketch for 1.5.2 images (first gen boards) for first gen boards, even tho the other sketch said for upgraded firmware. This worked for expanding. But still not sure about teh factory reset not working.