Arduino Zero Error: unable to open CMSIS-DAP device 0x3eb:0x2157

I am trying to upload the Arduino Blink application to my new Arduino Zero board.

However the following verbose error occurs:

Open On-Chip Debugger 0.10.0+dev-gf0767a31 (2018-06-11-13:36)
Licensed under GNU GPL v2
For bug reports, read
	http://openocd.org/doc/doxygen/bugs.html
debug_level: 2
Info : auto-selecting first available session transport "swd". To override use 'transport select <transport>'.
none separate
adapter speed: 400 kHz
cortex_m reset_config sysresetreq
Error: unable to open CMSIS-DAP device 0x3eb:0x2157
Error: No Valid JTAG Interface Configured.
Error: No Valid JTAG Interface Configured.

I use Windows 10, Version 2004 (OS Build 19041.804).

I have plugged in the USB cable in the “Programming Port”.

I have installed Arduino 1.8.13 (Windows Store 1.8.42.0).

In Device Manager, I have verified that the Driver Atmel Corp. EDBG CMSIS-DAP and reports This device is working properly.

I have tried with a second Arduino Zero Board with same result.

Hi cholm321,

Have you tried uploading a "blink" sketch on the native USB port?

If the sketch won't upload over the native USB, then try double tapping the reset button. This will place the microcontroller into bootloader mode. You host computer should disconnect and reconnect on another COM port. In the Arduino IDE go to Tools->Port and select the new port then click on upload.

If the sketch has successfully uploaded over the native USB port, try switching back to the programming port and attempt to upload again.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.