Arduino zero problems,

I keep getting this.

Warning: platform.txt from core 'Arduino SAMD (32-bits ARM Cortex-M0+) Boards' contains deprecated recipe.ar.pattern="{compiler.path}{compiler.ar.cmd}" {compiler.ar.flags} {compiler.ar.extra_flags} "{build.path}/{archive_file}" "{object_file}", automatically converted to recipe.ar.pattern="{compiler.path}{compiler.ar.cmd}" {compiler.ar.flags} {compiler.ar.extra_flags} "{archive_file_path}" "{object_file}". Consider upgrading this core.

And this,

C:\Users\kaptindan\AppData\Local\Arduino15\packages\arduino\hardware\samd\1.6.2\cores\arduino\USB\USBCore.cpp: In member function 'uint32_t USBDeviceClass::send(uint32_t, const void*, uint32_t)':

C:\Users\kaptindan\AppData\Local\Arduino15\packages\arduino\hardware\samd\1.6.2\cores\arduino\USB\USBCore.cpp:649:8: warning: pointer of type 'void *' used in arithmetic [-Wpointer-arith]

data += length;

^

Sketch uses 10,876 bytes (4%) of program storage space. Maximum is 262,144 bytes.
Open On-Chip Debugger 0.9.0-gd4b7679 (2015-06-10-22:24)
Licensed under GNU GPL v2
For bug reports, read
http://openocd.org/doc/doxygen/bugs.html
debug_level: 0
adapter speed: 500 kHz
adapter_nsrst_delay: 100
cortex_m reset_config sysresetreq
in procedure 'program'
in procedure 'init' called at file "embedded:startup.tcl", line 473
in procedure 'ocd_bouncer'
** OpenOCD init failed **
shutdown command invoked

I have the board set to Arduino/Genouino Zero (Programming Port)
Port Com 3(Arduino/Genouino Zero (Programming Port))

HELP! Thanks!

The Arduino IDE 1.6.5 works fine for me on Windows 7 & 8. I read about some problems similar to yours with 1.6.6 and I haven’t tried the just-released 1.6.7, so my suggestion would be to drop back and try 1.6.5, then move cautiously to the newer IDE version.

So I found one issue, I have the USB host shield attached to the zero when I try to program it, it will not work, I take the shield off and it does. So the zero will not work with the USB host shield??

I tried to download code, but it is not successful.
The message shoe as below:

Arduino:1.6.10 (Windows 7), 板子:"Arduino/Genuino Zero (Programming Port)"

Open On-Chip Debugger 0.9.0-gd4b7679 (2015-06-10-22:24)
Licensed under GNU GPL v2
For bug reports, read
http://openocd.org/doc/doxygen/bugs.html
debug_level: 0
adapter speed: 500 kHz
adapter_nsrst_delay: 100
cortex_m reset_config sysresetreq
in procedure 'program'
in procedure 'init' called at file "embedded:startup.tcl", line 473
in procedure 'ocd_bouncer'
** OpenOCD init failed **
shutdown command invoked

上傳草稿碼時發生錯誤

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

Please help me how to fix this problem?

thanks,

Darren