Arduino Zero - Selected serial port does not exist

Hello everyone!

I recently got a new Arduino Zero board. I connected it via the USB cable to my computer and tried running the Blink code. However, it returns an error saying "The selected serial port does not exist and your board is not connected". Here is a list of things I've tried but haven't worked:

  1. Trying a new USB cable
  2. Restarting the computer and running 'Blink'
  3. Trying both the 'Native USB port' and 'Programming port' on the Arduino Zero
  4. Resetting the Arduino and running 'Blink'

I checked the device manager and the COM port for the Zero is named as USB serial device. Could anyone help me resolve this issue?

Hi @vedsoni1996

Try connecting the USB cable to the native USB port and double tap on the reset button two times in quick succession. This should put the microcontroller into bootloader mode and you should see or hear it reconnect to you host computer.

Next go to the Arduino IDE menu, select Tools->Port->COMx then try to upload your blink sketch oncemore.

Hi Martin! Thanks a lot for responding.

I followed your directions: changed the port to the native USB port, tapped the RST button twice quickly, and made sure the correct COM port was selected. I uploaded Blink after that, and I still get the error:

"No device found on COM9. An error occurred while uploading the sketch."

@vedsoni1996 Have you downloaded the Arduino SAMD Boards package?

In the Arduino IDE go to Tools->Board->Boards Manager, then type in "Arduino Zero" in the search box. Next install the package, current version is 1.8.11.

Hi Martin! Yes, I have the Arduino SAMD package installed with the latest version. One small update. When I run Blink, I get the error, but I noticed that the orange LED named RX blinks. I was expecting the green LED named ON or the RGB LED to blink. However, I still get the device not found error. I tried this process on another computer as well with the same result.

So when you plug in the board on say the native USB port, can you see the COM port in the Arduino IDE under Tools->Port->COMx? And you've selected this COM port?

Yes, I have. It shows up as COM9.

So if you now double tap the reset button, does the board disconnect from that COM port and reconnected to a COM port with a different number?

When I double tap the RST button, the RGB led momentarily turns off for a second and starts blinking again. However, the COM port on the device remains the same. I checked under Tools>Port.

And you're connected to the board's Native USB port?

Yes I am.

Just covering the obvious, in the Arduino IDE is the board also set to Arduino Zero (Native USB Port)?

Yes. That is where I am checking that the board is set to the native USB port. On the Arduino Zero board, I see only one USB port, which is a USB B. Are the native USB port and programming port physically different?

I'm really sorry for bothering you regarding this Martin. I thought that I had ordered a Zero, but I have an Arduino UNO here. That explains the problems I'm having. Really sorry about this.

Glad to hear that you solved it. I was really no trouble, sometimes simply discussing the problem can help pinpoint where is issue lies.