Arduino Zero stalls on macOS startup

Hello all,

I am running into a problem where if I have an Arduino Zero plugged into a Mac (using the Zero's Native USB port), the sketch on the Zero freezes / stalls approximately six seconds into the Mac's startup routine. I.e. if the Mac is off and the Zero is plugged in (using the Zero's Native USB port), when I hit power on the Mac, the sketch on the Zero runs for approximately six seconds and then freezes. And when the computer boots fully up, the Mac doesn't see the Zero on the USB port. If I unplug the Zero from the Mac and plug it back in (when the Mac is running), the Zero behaves normally.

Even when the Zero is getting power (through the Programming port) and it's connected to the computer through the Native USB port, the Zero freezes approximately six seconds after I push power on the Mac. If the Zero is connected to the Mac through the Programming port, it doesn't freeze as the Mac is starting up.

This behavior is consistent across multiple Zeros and is consistent even when I have a very simple sketch running on the Zero. The behavior is also consistent across multiple Macs.

We tested the Zero plugged into an Asus laptop running Debian, and the Zero didn't freeze when the Asus laptop booted up. I've also tested Arduino Leonardos and Arduino Dues with the same Mac, and they don't freeze when the Mac starts up.

I've tried putting a 10 second delay in the startup routine on the Zero, but the Zero still freezes when the Mac boots up, suggesting that some interrupt is being triggered on the Zero by something coming from the Mac as it boots up.

Any ideas how to prevent this from happening?

Thanks,
Carl

Yes, never turn off the MAC.

Lol, that is what I have been doing. But the Zero runs my adaptive keyboard and mouse (I have a disability), so if the computer restarts for some reason, I am stuck not being able to use my computer.

have you tried adding a powered USB hub in between your Mac and the Zero?