Arduino Zero Standalone - USB communication problem

Hi guys,

I bought an ATSAMD21G18A chip and soldered it in a breadboard to make my Arduino Zero standalone. Then I made the circuit and burned the arduino zero bootloader using ATMEL-ICE and ATMEL Studio successfully.

I’m now trying to connect my chip to the Arduino IDE to upload a program through USB, but my USB connection is not working. When I connect the USB cable to PC, I get an “Unrecognized Device” from Windows, and I’m not able to select the COM Port in Arduino IDE. I already tried to upload the program in Arduino IDE even with no port selected, but I always got the message that no board was identified. I tried also to press reset button twice to get in or out of bootloader mode, but nothing happens.

I already uploaded three bootloaders: Arduino Zero, Arduino M0 and Adafruit Feather M0. Same result with all of them.

I don’t think it’s a problem with Windows Drivers, because any other Arduino board I connect to the PC, it’s identified/recognized by Windows and I’m able to upload any program using Arduino IDE.

Attached is the schematic of the circuit I’m using.

Am I missing something that is necessary to establish the USB communication between my board and the PC?

Thanks,

Daniel Reis

I am not sure about how you connected the USB to the chip. Seems like you need a USBAsp or Arduino as ISP to bootload an ATMEGA chip. Once bootloaded you can use a USB FTDI cable or USBAsp or Arduino ISP to program it

Hi sarouje, we are using an ATSAMD21 chip, it’s not an ATMEGA.
We already burned the bootloader.

The ATSAMD21 chip doesn’t need and FTDI chip, because it has a built in USB, with native USB-to-Serial capability.