Arduino15 Library MISSING

I am trying to do something really simple like the "Blink" example.

But any time I try to run anything, I get an error message:

Arduino: 1.8.10 (Mac OS X), Board: "Arduino Nano, ATmega328P"

fork/exec /Users/.../Library/Arduino15/packages/arduino/tools/avr-gcc/7.3.0-atmel3.6.1-arduino5/bin/avr-g++: no such file or directory Error compiling for board Arduino Nano.

This report would have more information with "Show verbose output during compilation" option enabled in File -> Preferences.

When I look for the Arduino15 folder, I can't find it. I have reinstalled several times and when I install, NOTHING appears except the application for the IDE itself. Why isn't it downloading the appropriate stuff?

When I try to Blink on the Web-based editor, it also says

Overriding Baud Rate : 115200

avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00

which I'm sure is a separate issue.

wwkuehster: fork/exec /Users/.../Library/Arduino15/packages/arduino/tools/avr-gcc/7.3.0-atmel3.6.1-arduino5/bin/avr-g++: no such file or directory

This error indicates you need to take some drastic action. Be aware this is somewhat advanced and will remove any boards you have installed via Boards Manager:

  • In the Arduino IDE, click the link on the line following File > Preferences > More preferences can be edited directly in the file. This will open the Arduino15 (or similar name depending on OS) folder.
  • Delete all files and folders under the Arduino15 folder except for preferences.txt. Please be very careful when deleting things from your computer. When in doubt, back up!
  • Restart the Arduino IDE

Verify that you can now use your board before reinstalling any packages via Boards Manager.

wwkuehster: When I look for the Arduino15 folder, I can't find it.

With the default settings, it's hidden from you. You need to configure Finder (or whatever it is, I have never used macOS) to show hidden folders.


wwkuehster: When I try to Blink on the Web-based editor, it also says

Overriding Baud Rate : 115200

avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00

which I'm sure is a separate issue.

Correct, but I can try to help with that also:

  • In the Arduino Web Editor, click the board menu.
  • Click "Select Other Board & Port".
  • From the "Boards" menu, select "Arduino Nano".
  • From the "Ports" menu, select the port of your Nano.
  • From the "Flavours" menu, select "ATmega328P (Old Bootloader).
  • Click the "OK" button.
  • Try uploading again.

If that doesn't work, let me know and I'll give you some other things you can try.

THANK YOU so much for your clarity. This was the most helpful advice I've gotten all week.

Both of those suggestions worked!

Yay! You're welcome. I'm glad to hear it's all working now. Enjoy! Per