arduino_16550_uart not found when build project

Hi,
I have seen this in other issues in github but I was not able to solve it with the suggestions proposed, also don’t know I I have the same issue (I run the scripts in ubuntu 18.04 but tried with sudo if this was the case but nothing).

I’m trying to build the MKRVIDOR4000_graphics project like proposed in repository.

At first I run the the apply_patch.sh line by line to see if anything is broken. after install the dos2unix the only strange thing I see is the 0x013 problem and don’t know what could be the problem:
dos2unix: Binary symbol 0x13 found at line 1
dos2unix: Skipping binary file arduino_16550_uart/top/altera_16550_uart.sv
dos2unix: Binary symbol 0x13 found at line 1
dos2unix: Skipping binary file arduino_16550_uart/top/altera_16550_uart.ocp

then go to the MKRVIDOR4000_graphics project and run the build_all.sh in nios command shell and get the error when building the qsys:
Error: MKRVIDOR4000_graphics_sys.nina_uart: Component arduino_16550_uart 18.1 not found or could not be instantiated

but the arduino_16550_uart and the pgm/arduino_generic_qspi_controller2 IP are located correctly in intelFPGA/18.1/IP/altera folder but the nios shell don’t find the IPs and the files are there.

if I change the IP to instantiate the altera component instead of arduino cores it generates correctly but i guess this is not the solution since then it breaks compiling the rest of the design.

what could be wrong?.
any workaround?.

regards.

The intel's core for 16550 uart is not free, it needs a license.
Same goes with Nios /f cpu softcore.
If you don't have a licenses installed, you should switch to "_lite" version of the project. The uart is disabled there entirely.

Hello @VStrkh i think this is not the problem, i have license for Quartus… but thanks for the info, the lite version compiles but I would like to go for the full version since people says it runs worst or slower.