ArduinoBT: BT connection crashes when uploading

Hello I'm a new ArduinoBT owner and I'm trying to get a darn program uploaded onto it... My board is powered by a 4,5V Duracell battery (well.. i actually measured 4,74V on the bat), i have Widcomm BT drivers I downloaded the 0010 software and had some problems and deleted it and tried 0009... same here, and now i'm runing on 0008. I paired the board with my pc, connected to it and ran the 0008. Loaded the Blink sketch, and when i press upload, the bt just crashes and in a few seconds its up again... the program says that the board was not found and it cannot upload to it and it says i need to reset it... Then I hold the reset button for 5seconds or so and right after i release it i click upload... the same happens... IDK what to do anymore... Help me please!


Edit: I forgot to mention, that i already checked the COM port

bumpedy bump bump bump

Anyone? :-/

The ATmega (5V models, anyway) do not like to be programmed at less than 5V. I have seen bizarre behavior ranging from simply not uploading the sketch to wiping out the bootloader while running on a 4.5V (3xAA) battery pack or a 6V battery pack with a standard 7805 regulator. Running a low dropout regulator (LP2985, IIRC) and a 6V pack cured the strange behavior.

-j

Oops, just noticed this was for a BT. these comments are for an NG.

The problem was that i tried to power it with 5,07V form a transformer and it didnt work... maybe there wasnt enough current...