arduinobt parallel programmer burned

hey!

i'm having trouble with my arduinobt, because i
accidentaly changed the serial-speed to something
other than 115200...

now i tried to flash the firmware as described in the
playground (Arduino Playground - BTWT11Interface),
but it doesn't work. the only effect i recogniced: the
smell of a burning chip - it was the 4050...

i am/was using a CD4050BE and everything seems
to be plugged as described in the tutorial...
(http://focus.ti.com/lit/ds/symlink/cd4050b.pdf)

the 3,3V+/GND, which should be connected to
pins 1 and 8 i grabbed from the batteries (2xAA)
that are powering the arduinobt.

you can see the complete setup at the image i attached.


hi

a burning smell is bad news, I would find out what's burning and why before hooking it up again. If you fed a positive voltage from the port or the Arudino to an output pin of the 4050, that would do it.

Also, your pictures are terrific but circuits that use all the same colour of wire are much harder to trace than those that use four or five colours of wire.

Probably not a good idea to hook up the BlueGiga to your computer directly, I would use an external programmer like the AVRISP MK2. There was a thread on someone who had the same problem, did you see it? If I remember correctly the way I have restored BT's in the past, I just hook up an AVRISP to the 6 pin header, upload a new bootloader to the Atmega and then run that once, which resets the serial speed of the BlueGiga to 115200. Once communication was established, I'd upload a user program with the device name to configure it.

D

thanks daniel!

yeah - i know the red-red-red-red-red... wiring is a little bit confusing.
the photos were ment to make sure that my basic wiring is correct,
especially that i supply the 4050 chip with the 3V from the batteries that
supply the arduino.

the 4050 is the ***** thats burning. but i doublechecked the wiring
and everything seems fine .. damn.

anyway - i ordered an avr isp mkII today. i think its not a bad idea
to have one, if you're working a lot with mikrocontrollers... :slight_smile:

good night and bye bye,
hans

hey Hans:

the usual things that makes chips burn are:

  • when you feed +5 into an output that is in the low state,
  • when you connect an output in high state to gorund,
  • when the power supply is too high of a voltage, or gets connected backwards.

try those possibilities out...

D

i'm back - and i brought an avrisp mkII with me
and tried to fix my arduinobt as explained in the
playground.

http://www.arduino.cc/playground/Learning/BurnBootloaderBT

... but it isnt working properly. everything seems to
be fine - the led in pin 13 is blinking like it should...

.. but windows can't find any bluetoothdevices :frowning:

hope someone can help me.

bye bye,
hans

hey Hans

do not despair... yet. :slight_smile:

Sounds like the Atmega is back to life. If windowds can't find BT devices, that's not good. Did you put the cinfiguration code in? that should reset the BlueGiga module. I'd try another computer to see if the BlueGiga is alive. It's either burned form your previous "smoking" incident, or just misconfigured. SO I would try to get it configured properly, and then if that doesn't work you could move to the despair mode.

D

woohoo!

:slight_smile:

(that damn bluetoothstick don't wanted to
recognize it - got a new one now and tada:
works)

thanks for your time,
hans