ArduinoBT upload issue; please help

Hello All,

I am a newbie using the arduinoBT for a college project.

I am unable to upload my sketch onto the arduinoBT. I have tried on Windows XP, vista and Win 7. 2 I am using arduino ide 0017

The arduino and my laptop are properly paired along with the setup of the virtual incoming and outgoing COM ports. I get the following errors:

avrdude: ser_open(): can't open device "\.\COM5": The system cannot find the file specified.

I also get the "Access denied error" on the COM port.

The serial monitor throws an exception saying: "Serial port 'COM 5' already in use. Try quiting any programs that may be using it."

  • I have checked and verified all the points in the "Troubleshooting guide"
  • I am unable to use Linux to pair the arduinoBT because of the fixed 5 char pin '12345' which is not accomodated currently in linux. -I have updated the JRE
  • I have tried to disable the COM port, reboot, enable port and retry the upload with no positive results. Its worth mentioning that in this case, the exception thrown by the serial monitor goes away, but returns after the first attempt to upload the sketch. There are times when the upload freezes too.

-I have even tried to turn off firewalls without any different results.

I should also mention that there are not issues with the upload of the sketch when I try it on my friend's mac. But this is not a solution for me.

I am in a serious fix with the project deadline looming large. Kindly help me!

Thank you! Mano

I am really hoping someone could throw some light on this issue I am facing with the ArduinoBT. Kindly help.

Hi mano,

have you ever uploaded a sketch to the Arduino-BT which does some Serial.print() calls in the loop() function?

The firmware of the the WT-11 chip has a bug which crashes it, when the receive buffer overflows. This happens very easily, when you call Serial.print() while no connection to the PC is established.

To get out of such a loop, you have to upload a new sketch before the old sketch starts to run. Instead of pressing the reset button for a short time before uploading a new sketch, you have to hold down the reset button before you connect the power to the Arduino-BT board. Now start the download and release the reset button (at the time when you normally press it).

MikeT

Mike,

Hats off to you!!! You saved my day...or was it days!!!

Its worked with your solution.

Thanks a ton!!

regards, Mano

hi!

I have exactly the same problem, when I try to upload on COM11 I get avrdude: ser_open(): can't open device "\.\COM11": Access is denied. and the serial monitor throws an exception saying: "Serial port 'COM 11' already in use. Try quiting any programs that may be using it."

I,m trying to solve this problem for 3 days now, and I'm going crazy :o. Can anybody help?? Please

OK, i finally did it! i'm not really sure how, but I think that there was a problem with connection in My Bluetooth Places with my Micronet USB Bluetooth. Everything looks good now.