ArduinoIPS error

I’ve purchased the AruinoISP from here (RS components)
http://uk.rs-online.com/web/p/processor-microcontroller-development-kits/8245444/43426

But having trouble installing the drivers for it, In device manager I see it down as AdruinoISP with ! mark over it, I click to update driver which I downloaded from here
https://www.arduino.cc/en/Main/ArduinoISP
point it to the folder but get error message in image, I’ve tried plugging it into another USB port and another computer and get the same errors on windows 7 64 bit

Anyone else had issues

Hi Steveiboy

I've tested the following on Windows 8 but hopefully works on Windows 7.

  • Without the ArduinoISP connected, run Device Manager and select Action - Add Legacy Hardware.

  • On next page, click Next.

  • Select option to install hardware manually.

  • Select show all devices and click Next.

  • Click Have Disk.

  • Click Browse and navigate to the folder where you have extracted and saved the drivers. Then select the arduinoisp.inf file and click Open.

  • Click OK. It should then list ArduinoISP under Model.

  • Click Next twice and you should get "Windows has finished installing the software for the device".

Then connect programmer and check status in Device Manager.

Regards

Ray

Thanks Ray I've now got it installed. And it's listed, I selected ArduinoISP as programmer and then upload using programmer it complies ok but then get error avrdude cannot find usbtiny and then some numbers can't remember as I'm not near PC to to get true error but will try to uninstall and try again and get true error and report Thanks for taking time to help Regards Steve

When you do test it, Steve, go into File - Preferences first and tick the box to select verbose messages for upload.

Then, if you still have problems, copy and paste all the messages from the window into a text file and attach that to your next post.

Which version of the IDE are you using?

I will do that tomorrow night, the ide is version 1.65 the latest version

Steve

Ray
I’ve tired what you said but still get error that it cannot find the programmer
Please see attached

Regards,
Steve

error text.txt (11 KB)

Thanks, Steve.

Just to check, does "ArduinoISP" appear in Device Manager? Any icon next to it?

Hi Ray
Yes it does please see attached image, Not sure if this has anything to do with it when I downloaded the IDE I used the advanced and copied and pasted the contents into the arduino folder ?

Steve