ArduinoOTA on MKR1010 WIFI

Dear all,

I am trying to get the arduinoOTA running on a MKR1010 Wifi.
The script and the library is compiling without any problems (with WIFININA), but I can't see the COM port via WIFI?

Has anyone get this running on a MKR1010?

Thanks so much!

ArduinoOTA library?
the problem with port is in OS or IDE. try the beta version 1.9 of the IDE

I have got this running on MKR1000 board.

Try using "WiFi101OTA" library.

I have got this running on MKR1000 board.

Try using "WiFi101OTA" library.

WiFi101OTA is for MKR1000 or WiFi101 shield on Zero
ArduinoOTA library is my modification of WiFi101OTA for other boards and networking libraries

Juraj. I have tried using your library and looked at the Github #7 & #8. They have not helped and I am still getting the same issue. No wireless com port is showing and I even switched to beta 1.9.0. Do you perhaps have any other idea what to do?

I have the same problem. Turns out that the anti-virus program somehow causes it. I'm using Avast (free) and only after completely removing Avast, the WiFi port shows up, reliably, and the OTA updating works flawlessly. Disabling Avast is not enough. I've done this on two different computers, same result on both IDE 1.8.10 and 1.9.0.
Of course this is not a sustainable solution, but it seems another AV is needed.


Some security programs can identify programming environments as malicious.
This is known as a false positive.

Avast has an EXCLUSIONS list to which you can add known good sources / programs / folders, etc.
You should re-install your antivirus and add the Arduino locations to its list.

Slow compiles or driver errors under Windows

Add the Arduino directories to your antivirus / anti malware / other security exclusions.

So that would be at least two of the following.

C:\Program Files (x86)\Arduino
C:\Users\yourname\AppData\Local\Arduino15 (depends on IDE install type/location)
C:\Users\yourname\AppData\Roaming\Arduino15 (depends on IDE install type/location)

If you have your sketches set up in a different location it’s also worth adding that directory to the exclusions also.

Additionally if you also use the online IDE “CREATE” the following directories.


If you have installed to a different drive swap the drive letter as needed.
If you also have an unzipped IDE installed that path should also be added to exclusions


Thanks Bob,

That fixed it.