Ardunio IDE is not opening in Ubuntu 16.04

I have installed Ardunio IDE (using Terminal ) by referring link guide: http://ubuntuhandbook.org/index.php/2015/11/install-arduino-ide-1-6-6-ubuntu/

but after creation of desktop shortcut : it shows an Icon of IDE opening on Launcher but ...after few second it vanishes...

can anybody help me to sort out this problem....

Open a terminal in the install directory. Type ./arduino in the terminal and press enter. Does it run, does it generate any error messages? What are the error messages, if any.

Did you install the latest version, 1.8.2?

tf68:
Open a terminal in the install directory. Type ./arduino in the terminal and press enter. Does it run, does it generate any error messages? What are the error messages, if any.

Did you install the latest version, 1.8.2?

same problem here. I followed you suggestion and I got the follow:

marcelo@marcelo-VPCEB42FM:~/Downloads/arduino-1.8.5$ ./arduino
Picked up JAVA_TOOL_OPTIONS:
java.lang.UnsatisfiedLinkError: /home/marcelo/Downloads/arduino-1.8.5/java/lib/i386/libawt_xawt.so: libXtst.so.6: Não é possivel abrir arquivo de objetos compartilhado: Arquivo ou diretório não encontrado
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1941)
at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1824)
at java.lang.Runtime.load0(Runtime.java:809)
at java.lang.System.load(System.java:1086)
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1941)
at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1845)
at java.lang.Runtime.loadLibrary0(Runtime.java:870)
at java.lang.System.loadLibrary(System.java:1122)
at java.awt.Toolkit$3.run(Toolkit.java:1636)
at java.awt.Toolkit$3.run(Toolkit.java:1634)
at java.security.AccessController.doPrivileged(Native Method)
at java.awt.Toolkit.loadLibraries(Toolkit.java:1633)
at java.awt.Toolkit.(Toolkit.java:1668)
at cc.arduino.view.SplashScreenHelper.(SplashScreenHelper.java:55)
at processing.app.Base.(Base.java:215)
at processing.app.Base.main(Base.java:144)
marcelo@marcelo-VPCEB42FM:~/Downloads/arduino-1.8.5$

it is the same error, it show up in the screen for couple seconds and disapear

any help?

I suspect you are running the 32-bit version of the IDE on a 64-bit Linux. Try the 64-bit IDE.

1 Like