I'm using an Arduino UNO to measure resistance across a PTC thermistor. I'm new to programming and I'm not sure how to continuously assign analogread values to a pin.
This is my set up code and I would like a for loop to iterate through analogReads assigned to each pin so that for example I could get reading1 = analogRead(THERMISTORPIN1);
You created a useful identity and then discarded it. #define THERMISTORPIN1 was a great idea, now you know what the pin is used for. But 'reading1' doesn't say that it is thermistor. After you take the reading, it's the 'reading1' value that you deal with. It would be better as thermistorReading1, or something like that. Same with 'resistance'... resistance of what? Often programs grow in size as features are added, and it's better to describe things completely so there is no confusion later.
It's not a big deal, but I see it happen too many times... someone starts out with great definitions and then forgets to carry them forward into the code completely.