AtMega 2560 firmware uploading Issue

Hello,

I am facing issue in uploading firmware "avrdude: stk500v2_getsync(): timeout communicating with

programmer" on Mega 2560. Troubleshooting states few points in this regards which seem okey in my case

like COM port selection, Boot loader etc.. I checked all the points stated in Troubleshooting and look good

to me, still facing the problem. Other Arduino boards work fine in my system, facing issue with only

Mega2560. It was working a day before suddenly it starts showing result as stated above.

Any idea how to resolve this?

Thank You!!

Did you try the Loopback Test in the Installation/Troubleshooting forum, to see if your USB/Serial interface is still working?

Hello

I tried by nothing is echoed back but following requirements look okey to me.

If nothing is echoed back,check:

  • You have the correct com port. —> Yes showing correct COM in device Manager with Device name . I

could select the same in Tools menu

  • Try a different cable.Some cheap USB cables only have power wires and not data wires. —> Yes tested

with different cable but not working

  • Check the device driver for the Arduino is installed . —> I tried updating the driver from device

manager and it shows driver installed.

Am I missing any stuff ?

Thank YOU!!