Atmega 2560 is heating a little bit

hello everybody,
I am working on a project for our rugby team, i am in making a device which logs data like location,Heart Rate,Acceleration and stores that into SD card, I have also implemented USB to SD converter chip (USB2240) on my 10 PCBs made from china…

I have ‘only’ soldered Atmega2560 and uploaded the nick gammon Booatloaders into the chip and then my code which logs data into SD card…I am supplying power from my Arduino UNO, I can feel heat over the chip by keeping my finger for a while…

what could be the cause of this problem.? I am attaching my schematics along with this thread…

Please check the section of only U2 which is Atmega2560 in the schematics…

NOTE : I have tested by "ONLY’ soldering the Atmega2560 chip, not everything…

Thank you…

sch file (2).pdf (85.6 KB)

mudassir9999: I can feel heat over the chip by keeping my finger for a while.. What could be the cause of this problem.?

How much current was the Atmega2560 using when you measured it ?

If the '2560 chip is hot, you have damaged one or more IO pins and it's just a matter of time until the chip fails completely and needs replacing.

thank you for reply,

How much current was the Atmega2560 using when you measured it ?

I have uploaded empty code, my DMM shows 26.5mA..

If the '2560 chip is hot, you have damaged one or more IO pins and it's just a matter of time until the chip fails completely and needs replacing.

I will replace this chip with the new one, when it's solved..