ATmega 328 with Uno Optiboot

Hi guys, I've recently bought the components to make an "Arduino" by myself. The IC I'm using is an ATmega 328 which was pre-installed with the Arduino Uno Optiboot. I used the following instructions as the basis of the setup:

http://makeprojects.com/Project/Build-a-Mintronics-MintDuino/608/1

However, I have been experiencing problems when it comes to uploading to the chip. It gives me this error message:

avrdude: stk500_getsync(): not in sync: resp=0x00 avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

Any assistance would be appreciated.

Koop

This errors, most likely, indicators that no response from the chip. Are you using FTDI usb to serial or serial link? How it connected, and can you see a port in arduino IDE?

Magician,

Yes, there is an appropriate port and I can see the TX LED blinking on my FTDI programmer. The programmer I'm using is this:

http://australianrobotics.com.au/products/sparkfun-ftdi-basic-breakout-5v

Could be something simple, like baud-rate mismatch or tx/rx swap between ftdi and atmega328.
Does atmega getting good +5V power?

Are there any chance to test ftdi separately, by connecting it to other serial TTL devise (old mobile)?
But anything more complicated, would require oscilloscope to troubleshoot, I’m afraid.

Does the green LED blink when the reset button is pressed? Could you post a picture or two?

Thankyou for all your responses.
I’ve narrowed down the problem to my FTDI programmer. I attempted to program my Duemilanove the same way as with the lone chip and it didn’t work.
Magician: How would I check the baud rate or see if the TX or RX have been swapped?
Jack: The LED (I assume you are talking about is 13’s LED) does blink when it is pressed.

In the attachments, I’ve added a photo of the setup.

If I’m not mistaken, Rx (D0->27) should be connected to Tx of the FTDI (it marked on board, see picture), and consequently Tx(D1->26) to Rx(FTDI).
Now , baud rate boot-loader, 19200 kb/s or 57600 kb/s I don’t remember for sure.
(It should be first question you asking on the forum! :slight_smile:
Where did you get Atmega328, does it have pre-programmed boot-loader?
You can’t programmed in this way chip that doesn’t have boot-loader.
And one more things, wires look not insulated, keep them as far as possible from crystal to prevent touching.

MKAD22-2.jpg

Its OK guys I worked it out by myself :) Thankyou for all your help!

Koop

(deleted)

i was getting that same error when setting up my arduino uno when I choose the port to be 3. Choosing port 4 fixed the problem for me.

EDIT: anyone confused I am talking about COM port...its in the list somewhere at navigation bar of arduino software.

My problem was that the FTDI programmer I used (See above) wasn’t providing a proper 5V, but 3.3V (They may have sent me the 3.3V version by accident, or it’s just the case with all of those programmers), and so the capacitors for the crystal weren’t charging and discharging at the proper rate, meaning that the ATmega chip was on a completely different time. This was simply fixed by using my own separate power supply as well, solving the problem. Hope that helped!

Koop :slight_smile: