ATmega1284P FTDI USB Serial Light Adapter


I've searched and searched trying to find an answer to my problem. I've followed these guides in order to setup and burn the bootloader!,80483.0.html

I'm using a Atmega1284P with a 16MHz crystal. I succesfully burned the Mighty 1284P Optiboot bootloader to the Atmega1284P using my arduino mega R3 (arduino ISP). When I tried to upload a sketch using my Arduino USB Serial Light adapter, all I get is random errors like:

avrdude: stk500_paged_write(): (a) protocol error, expect=0x14, resp=0x64
avrdude: stk500_cmd(): programmer is out of sync

I saw a lot of folks here with the same problem but didn't find any solution. I tried a bunch of bootloaders with the same results. The Piccaso Mighty slow Optiboot bootloader made uploading sketches possible. But the results is still very variable. Sometimes I get the error i mentioned above and sometimes I get a successful upload. I think the problem lies in the baudrate but still I'm not sure.

The Piccaso slow bootloader uses a baudrate of 28800. Is it possible to take the baudrate down to 19200 or maybe even 9600? Which files do I have to change (except for the Boards.txt file)?

And if i'm wrong, then what's the solution to this problem? Going nuts here!!

P.S Am using Arduino 1.0.1 D.S