atmega1284p/pu

Yours:

mighty.bootloader.file=ATmegaBOOT_1284P.hex
mighty.upload.protocol=stk500v1
mighty.bootloader.path=standard

Mine:

cube1284p_16.bootloader.file=optiboot_atmega1284_16.hex
cube1284p_16.upload.protocol=arduino
cube1284p_16.bootloader.path=optiboot

Compare the two again, are you absolutely sure they are the same.
(I am assuming you have downloaded the bootloader file and saved it into the folder \hardware\arduino\bootloaders\optiboot\ )

Try changing the three lines I mentioned to this:

mighty.bootloader.file=optiboot_atmega1284_16.hex
mighty.upload.protocol=arduino
mighty.bootloader.path=optiboot

Burn the bootloader again, and then see what happens.

can i bootload bootloader twice?

i booted burnloader again now using optiboot and i still cannot upload program and i get the same error as previosly.

Could you post a picture of your wiring.

here it is but i think its useless because if it was wrong i would´nt boot bootlader

Where's the 10K reset pullup resistor? Where's the 100nF caps for Vcc, AVcc to Gnd?

Talking with the bootload and burning it are two different processes and require different wiring (one uses UART, one uses SPI), so just because one works, doesn't mean the other will.

Fortunately, having looked at the second picture you uploaded, I can see the problem. You may recall I said that you had to use UART1, not UART0. Look at your wiring again and see which you are using (Hint: RX1 is on pin16, TX1 is on pin17)

i tried both uarts but none of them works. 10k resistor is inside the rs232 cover and caps are not necessary because there is one, 1000uf. i guess it is enough. on the breadboard is also connected atmega328 and that one is working 100%, i used that as isp. i still get the same error while uploading as i wrote on one of my previous post. has anyone any idea?

Not In Sync... RX=0x00 generally means one of two things:

1) that the bootloader is wrong and not responding - it works fine for me, so I see no reason why it shouldn't for you. Edit: Unless it is because this reset vector is wrong because you didn't set your fuse settings to match mine:

mighty.bootloader.high_fuses=0xdc

should be:

mighty.bootloader.high_fuses=0xde

2) that your wiring of the serial port is wrong. Disconnect the tx and rx pins from the atmega chip, and connect them together. If you send something through the serial port with the serial monitor in arduino, do you get the same thing back? This is called the loopback test, and will check your RS232 to UART converter is working properly. Edit: Looking at the inside of your RS232 plug, there are two things that stand out - firstly you havent connected pin 5, which is GND and is needed. Secondly, you have connected the DTR signal directly to the reset capacitor without any level shifting - this will result is a -18V or +28V spike on the reset pin whenever the DTR pin toggles. 28v + Atmega1284 = Bad

The other think to mention is just because you have a 1000uF capactor on the power rail, it doesn't mean you don't need a 100nF capacitor placed close to the microcontroller on the power rail. The two do totally different things - one smooths out low frequency ripple, the other filters out high frequency noise.

rs232 plug is connected right i just have 30 pictures step by step of it and i choose one randomly. anyway i have bootloaded mighty 1284p 16mhz using optiboot so my line looks like this:

mighty_opt.bootloader.high_fuses=0xde

loopback is not working :0 but i can upload code to arduino uno. thats weird.

If you have an arduino Uno, can I make the suggestion that you put a wire between the Reset pin and Gnd of the power header. Then connect the TX pin (D1) to the TX1 of the atmega1284, and the RX pin (D0) to RX1 of the atmega1284. That should allow you to remove your RS232 converter from the possible list of problems by using the converter built into the arduino board.

after all it’s working XD. the problem wor with max232. i have made ft232rl circuit and now it works. im using optiboot but it’s using rx0 and tx0, weird. anyway i wanna thank for your help. it shouldn’t be done without you, thanks.

[quote author=Tom Carpenter link=topic=121305.msg920811#msg920811 date=1347393995] I've been using the atmega1284 without issue (you like I did got the atmega1284-PU, not the atmega1284P-PU - Note that the PU specifies a DIP package and is nothing to do with the device).

All I had to do is to find the definition for ATmega1284P (just using CTRL-F), and change the signature to:

signature = 0x1e 0x97 0x06;

Then I used the IDE to burn a version of optiboot bootloader compiled for the mega1284p

Then once the bootloader was burned I changed the signature back to: signature = 0x1e 0x97 0x05;

It works a treat for me.

If you let me know what clock frequency you plan to use, I will compile an optiboot hex file for you. Note that the version I modified uses UART1 for programming. [/quote]

Hi Tom, please please please could you help me with getting this bootloader onto my Atmega1284P-PU chips, i have 2 of them also and have been trying my very very best to figure out how to do this for the last 2 weeks but after failure after failure i really could do with your help!

I have the Atmega1284P-PU microcontroller, i had downloaded loads of different hex files, optiboot files and now im so confused, lost and disheartened by all these failures of mine.

Ive been using the Arduino as ISP sketch uploaded to a Breadboard RBBB and trying to burn any Sanguino-Type bootloader onto the Atmega1284P-PU with absolutely no results, please could you put out a quick step by step list of what needs to be done in order to burn a bootloader to this microcontroller, i really feel like ive lost the war over here, please please could you help. a Great-Many thanks in advance,

kindest regards,

Anil Sethi Jnr

Try this bootloader, should allow serial downloads on Serial 0 afterwards.

It’s the one I put on my cards when I build one up with a '1284P; for example, installing bootloader from Atmek AVR ISP MKii with FTDI 5V Basic providing power, and then downloading a sketch.

Here’s the boards.txt entry that goes with it

bobuino.name=Bobuino
bobuino.upload.protocol=arduino
bobuino.upload.maximum_size=130048
bobuino.upload.speed=115200
bobuino.bootloader.low_fuses=0xff
bobuino.bootloader.high_fuses=0xde
bobuino.bootloader.extended_fuses=0xfd
bobuino.bootloader.path=optiboot
bobuino.bootloader.file=optiboot_atmega1284p.hex
bobuino.bootloader.unlock_bits=0x3F
bobuino.bootloader.lock_bits=0x0F
bobuino.build.mcu=atmega1284p
bobuino.build.f_cpu=16000000L
#bobuino.build.core=arduino:arduino
bobuino.build.core=standard
bobuino.build.variant=bobuino

This pins_arduino.h file goes in the arduino-1.0.x/hardware/mighty-1284p/variants/bobuino folder.
Should already be there if you’ve installed the mighty1284 files that maniacbug put together

optiboot_atmega1284p.hex (1.47 KB)

pins_arduino.h (6.08 KB)

!!! DUDE !!!

Thank you so very very Very VERY MUCH !!!!!

Honestly speaking, i think i was about to break down and cry my eyes-out, lol !!!

Got the mighty-1284p bootloader with 16 Mhz crystal bootloaded and got the blink sketch blinking away and uploaded the sketch via TX0/RX0 (UART 0) !!!

8) Your an absolute LEGEND !!!! !!!! !!!! 8)

Ive burned a good load of Atmega328P-PU's so kinda knew what i was doing but this Atmega1284 is a whole new type of animal, lol !

I really cant thank you enough ~ !!!

Glad to help.

Just go to settings, and change the type de board to the appropriate one it should work without any problem

Excavation. 8)