ATMega1284p using with W5100 Ethernet module

Hi Has anyone tried the Atmega1284p running Mighty 16 Mhz opiboot to use a w5100 ethernet module or shield? Are and devices or limitations I should be aware of using this chip in future projects. I choose it do the vast sram count of 16k and 32 pins for I/o. I have the bootloader installed and loaded the blink sketch which works great.

I appreciate you replies and experience using the ATMega1284p Adruino. Thanks Don

I don't know if anyone has done this, but the pinouts for the 1284 SPI port have to match the pinouts on the ethernet shield. The Bobuino is about the only board where these should matchup with a regular Arduino ethernet shield, I think.

I have my ATMega1284p on a bread board presently so I was thinking of using male/female jumpers I have to connect my ethershield up and if it works purchasing a w5100 standalone module to use.

I would just go ahead and try it with jumpers to the shield, and the standard library. I've been using the 1284 for everything except ethernet so far, and it works fine. Also, at 5V and 3.3V.

Good to know I have a couple of ATMega2560 board but looking to to divorcing my project from the Arduino board and making a pcb board. I'll try it and post the results here. Don

BTW, if you put "1284 ethernet" into the search box on top of the forum page, you'll find some other threads, including this recent one, http://forum.arduino.cc/index.php?topic=155330.0

It's in German, but no problem if you are unilingual and have Google Chrome, you just right click on Translate to English.

I'll be interested to see how you fare, as I have an ethernet shield too, but haven ever used it as yet, with 12,000 other projects going on, sheesh :-).

Hey Frisky, I don't know where you're at with this, but I finally got around to trying out the ethernet shield [standard Arduino compatible type] with my 1284P board today. Works fine, although took a bit of playing. BTW, I hadn't ever used the ethernet shield before, so I'm no expert on this.

  1. I first tried the shield with UNO and Mega boards, since they're more of known quantities, and tried the ethernet example sketches found in IDE v1.03. I connected the shield to my router hooked into Charter Internet.

  2. the WebClient sketch would not work, I think possibly because the server IPAddress as given is wrong. The DnsWebClient sketch did work correctly the first time, however, so that's what I used for the next.

  3. after trying UNO and Mega boards, I hooked the shield to my 1284P board. This didn't work right off, as I expected it wouldn't. Namely, because as we've found in the past, many of the libraries don't include support for the 1284P.

  4. I knew what to do from previous experience, but tracked down Nick Gammon's comments, see reply #8 and #13 here,

http://forum.arduino.cc/index.php?topic=112293.msg845635#msg845635

  1. I also had to jigger the shield, because the SPI pins from the Wiz5100 chip only go to the ICSP header, and not to pins D11..D13 of the Arduino header. My 1284 board does not have the ICSP header in the "standard" position, so I added 3 jumpers on the shield.

  2. now it works great. The google search dump from the DnsWebClient sketch is 82KB [forum attachment limit is 4KB], so I posted it online. It's long, and certainly the poor Arduino cannot make much hay out of it, but it all works end-to-end now. You can look at the htm page in your browser. The links get redirected in the download, so they don't work directly without stripping off a lot of garbage, but the standard search info is there.

http://www.ot-hobbies.com/sw/subs/webtest-1284-4.htm

  1. sometimes the figures on the HTML page show up, and sometimes they don't. I thought maybe the Arduino misses some characters here and there, so I tried stepping the RS232 baudrate up to 230400 [and using a standard terminal emulator], but that didn't seem to change much.

So, success here. Good luck.