I plan to build an ARDUINO serial board but using an ATMEGA168 in place of the AT MEGA8.

Where is the firmware ( HEX file ) to use for the AT MEGA 168 ?

Best regards


try this...

I gave this a try, but I was never able to get avrdude installed on my mac (I'm linux handicapped). Is there any tutorials for using AVRstudio or another windows software for the 168?

Well I finally got avrdude installed and running (I think). But when I try to run it with this:

daniel-parks-computer:~ amsmntparks$ avrdude -patmega168 -cponyser -Pusb -b115200 -u -v -U hfuse:w:0xdf:m -U lfuse:w:0xc7:m -U efuse:w:0x08:m

I found it in the forum you pointed me to. But I'm using a different programer and the output I get is this:

avrdude: Version 5.1 Copyright (c) 2000-2005 Brian Dean,

System wide configuration file is "/sw/etc/avrdude.conf" User configuration file is "/Users/amsmntparks/.avrduderc" User configuration file does not exist or is not a regular file, skipping

Using Port : usb Using Programmer : ponyser Overriding Baud Rate : 115200

avrdude done. Thank you.

(I also tried it at 9600 baud) When I try to put the LED blink program on it, I still get the programmer not responding error. Suggestions?

I'm interested to hear the answer to this too, as I am trying something similar on mac.

Anyway, to me it looks like AVRdude worked. the probelm is you need more command lines-- the one you have just sets the fuses. You need also to unlock it the first time around, and then another line to upload and burn the hex file.. etc etc.

Wolf Paulus has a really excellent page on this.... He shows three steps, as does the original Arduino burn.command that used ot use UISP to do the same thing.

Keep the info coming, it is really useful.


my test show me that avrdude produces a nummber of errors while writing fuses to an atmega168 the same exact setup programs well on windows with avr-studio

the latest build of parallels is really good for testing this :)


Victory!!! I followed the tutorial in the link above and got it working. The only problem I ran into was that avrdude wasn't installed where it said (could be because I tried to install it earlier). Once I figured that out, I put my hex into the same directory as avrdude and ran all three commands from the link. Switched everything over to arduino programmer and got the LED blink working just fine. So thanks a million for that link!

I think the -Pusb might not be right. What kind of programmer (or usb-to-serial converter) are you using? Does it create a virtual serial port in /dev (e.g. /dev/tty.SOMETHING)? If so, you need to pass that to the -P argument.

Also, I’ve successfully burned the bootloader onto an ATmega168 using an avrude, an AVRISP, and a Keyspan USB-to-serial converter, but it only works about half the time (if it fails, just try it again, it doesn’t seem to damage the chip).

Another URL for the m168 bootloader: