ATMEGA2560 bootloading problem

Hi everyone,
Today I tried to upload the Arduino bootloader onto my self made arduino-compatible-mega-board. I used my present arduino to upload it. After 4minutes of uploading I got an error: “Error while burning bootloader, avrdude.exe: verification error, first mismatch at byte 0x1e000”.
I got the same error after 3 other uploading attempts. However, I tried to find something in the avrdude output. For me it seems like the communication with the ATMEGA2560 is working, avrdude sends the hexfile. But at the data-verification-procedure, the uC seems to send only FFs.
An other hint: The LED on pin 13 “doubleblinks” recurrently after uploading.

The full AVRdude Output is in the attachments.

Anybody knows whats going on?

Thanks in advance, Andy

AVRdude_Output.txt (2.04 MB)

The protocol used by ArduinoISP isn't normally capable of programming a device with more than 128KB of flash. (MANY programmers don't handle this.) IIRC, avrdude ends up being clever (but slow) about the programming step, sending many "raw SPI transaction" operations, but falls down during the verification step (reads the first 128k twice.) This may mean that your 2560 is properly programmed with the bootloader even though you're seeing an error message (the double-blink is a good sign.) Have you tried uploading a sketch?

Hi westf,

...that was actually the case ;) I tried uploading and it actually works just fine.

However that means I spent about one full day solving a problem that didn't really exist. :(

Thanks for your explanation.