ATmega2560 custom board upload issues [SOLVED]

Hello All, I apologize if I have incorrectly placed this post, got a little confused as to where to put it,

I have made a Arduino Mega 2560 "clone", just your standard Mega with a integrated motor driver, and am having some issues uploading the sketches to the board. Whenever I upload a program, it does the standard "uploading program to I/O board" message, but never actually does anything, it just sits like that infinitely. When holding down shift while pressing the upload button, it spews out "timeout" messages. I believe it may be a corrupt bootloader, but I have tried installing three different bootloaders with AVR studio, AVRdude, and the Arduino IDE itself, using both the Sparkfun USB Pocket Programmer and the pololu usb avr programmer. Using avrdude and pocket programmer, it programs well enough using

avrdude -c usbtiny -p atmega2560 -U flash:w:bootloader.hex -B10

although at the end of verification it warns of inconsistencies, but the site I downloaded the bootloader from said to ignore it.

Using AVR studio and the Pololu programmer it programs perfectly.

Using the bootloader upload menu in the arduino IDE just spews out an error about the device signature not being correct, the same error that I can get if I remove the -B10 in avrdude.

With all of these setups, I still have the same problem with the arduino sketches: a frozen upload.
I have also tried uploading through a external ftdi usb-serial dongle, but to no avail.

If anyone could help solve this problem, I would be grateful.


PS. Forgot to mention I am using 0023 and Windows XP

PPS. I know that this is a known issue, a timeout error, however, all of the solutions that have been posted have not worked for me.


Just Figured it out, the reset pullup was connected to ground.