ATmega328 + 16x2 LCD Display

Hallo liebes Forum,

ich spiele jetzt schon seit ein paar Monaten mit meinem Arduino rum und das erste größere Projekt, ein Intervall-Auslöser (IVAT – C3D2), nähert sich der Vollendung.
Der Auslöser soll unabhängig von der Kamera mit Strom versorgt werden und soll dementsprechend mit Batterien betrieben werden. Mein Plan ist, meine Schaltung ohne Arduino-Board sondern nur mit dem ATmega328 (plus dafür notwendige Bauelemente)und den für die Funktion notwendigen Bauelementen auf eine extra Platine zu verlöten, da ich mein Arduino nicht für den Auslöser Opfern möchte.

Nun befindet sich in meiner Schaltung auch ein 16x2 LCD Display, das auch mit Strom versorgt werden möchte. Wenn ich das den Datenblättern richtig entnommen habe, dann verbraucht das Display ~140mA Strom und der ATmega nur ~2mA.
Kann mir jemand sagen ob diese Werte stimmen könnten?

Datenblatt LCD: http://www.earthshineelectronics.com/attachment.php?id_attachment=3

Datenblatt ATmega328: http://www.atmel.com/dyn/resources/prod_documents/doc8271.pdf dort auf Seite 320

Falls die Werte stimmen, dann komme ich ja auf einen ungefähren Verbrauch von 150mA.
Wenn ich das ganze jetzt mit 4 Akkus (1,2V; 4000mAh) mit Strom versorgen möchte, dann komme ich auf 4,8V und 16000mAh.
Nach meiner Rechnung käme ich über die Gleichung
t=Q/I
t=16000mAh/150mA
t~100h
auf über hundert Stunden? Das kann ich mir irgendwie nicht wirklich vorstellen bzw. es würde mich sehr wundern.

Hat jemand Erfahrung damit, ob man ein LCD Display so einfach mit Batterien betreiben kann?

Ich hoffe auf eure Hilfe, wenn ich das ganze fertig habe, werde ich auch eine ausführliche Anleitung und die Schaltpläne unter einer Copyleft Lizenz veröffentlichen…

MfG r0oland

Wenn ich das ganze jetzt mit 4 Akkus (1,2V; 4000mAh) mit Strom versorgen möchte, dann komme ich auf 4,8V und 16000mAh.

Nee, wenn Du die Akkus in Reihe schaltest hast Du 4,8V und 4Ah, parallel hast Du 1,2V und 16Ah. Aber nicht beides. ;)

Problem dürfte auch noch sein, dass die Spannung mit der Zeit absinkt und spätestens bei 3,5V dürfte Schluss sein, schätz ich jetzt mal wild, insofern kommst Du vermutlich auch nicht an diese rechnerischen Werte ran.

Wenn ich das ganze jetzt mit 4 Akkus (1,2V; 4000mAh) mit Strom versorgen möchte, dann komme ich auf 4,8V und 16000mAh.

Bei einer Serieschaltung von Akkus erhöht sich nur die Batteriespannung. Der Strom/Zeit in Ah bleibt gleich. Somit hast du dann ein Akkupaket mit 4.8V/4000mAh

Und somit stimmt auch die nachfolgende Berechnung der Zeit nicht. :(

Ok, aber wenn ich einen Akkus nehmen, die 4000mAh haben, dann komme ich ja dann trotzdem auf t=4000/150=26,6h also auf über einen Tag...

Ok, das klingt aber schon realistischer. Meine Idee war, dass ich die Beleichtung des LCD einfach abschalte in der Zeit, in der ich den Auslöser nicht betätige. Ich brauch ja nur was sehen, wenn ich was einstellen will...wenn er dann die Bilder macht, muss das Display ja nicht leuchten...

Dann sollte es doch aber gehen oder?

Hat jemand erfahrung damit, ob es einfach ist, den Chip mit dem Arduino Board zu beschreiben und ihn dann in einer externen Schaltung zu verwenden?

MfG r0oland

Hallo rOoland,

dein Display verbraucht ohne Beleuchtung max. 1,5 mA! Mit Beleuchtung je nach Einstellung des Vorwiderstandes typ. 130 mA! Schalte die Beleuchtung mit einen Taster oder Schalter ein, dann hält die Batterie schon eine Weile.

Den Chip kannst du ja im Arduino Board beschreiben, dann ausbauen und in eine eigene Schaltung einbauen. Ich weiß ja nicht welches Arduino Board du besitzt, mein Duemilanove zieht ca. 40 mA, das ist für Batteriebetrieb schoin viel!

Aber der Atmega und ein bischen Perepherie herum, ohne USB braucht sicherlich nur ein paar mA. Es gibt ja 328er mit programmierten Bootloader, so daß du den neuen Chip wieder in dein Original-Board einsetzen kannst.

Gruß

Jürgen

Hallo, könntest Du mal interessehalber auflisten, welche "Peripherieteile man benötigt, um den ATmega328 und das lcd display per batteriebetrieb zum laufen zu bringen, ohne das Arduinoboard? Das finde ich sehr interessant, allerdings reichen bei mir die elektronikkenntnisse nicht ganz um das selbst hinzukriegen...

Wenn ich das richtig verstanden hab... Also. Um den Mega zum laufen zu bringen brauchst du... 1.Einen 16MHz Quartz (Dient als "Taktgeber" für den µController)

  1. 2x Lastkondensatoren (2x ungefähr 11pF)

Bitte Berichtigt mich falls ich jetzt mist erzählt habe. Wie du alles zu verkabeln hast weißt du denke ich mal. Und sonst Fragen. Dir wird bestimmt jemand helfen ;D

MfG

Das Datenblatt sagt 22pF Kondensatoren und die sollten zusammen mit dem Quarz so nahe wie möglich am ATmega plaziert sein. ansonsten hier http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1280927634

Grüße Uwe