Atmega328 Serial Connection problem

Hi guys....

I have a problem. I can't upload codes to my Atmega328. I built my own Arduino on a breadboard. I guess it is a typical problem that other people has too =( (Photobucket | The safer way to store your photos... )

-Windows XP
-Have a bootloader
-LED 13 blinked when reseted or tried to upload code
-I used a USB to RS232 with Prolific chip, did a loop test and data are bounced back
-Build the circuit based on this :

I built a simple MAX232 circuit to step the RS232 to a TTL level and into the Atmega328. I use 0.1uf ceramic cap and assembled it on the same board with my Atmega328. I tried to test the TTL signal using 232ANALYZER and I shorted the TX and RX wires from the MAX232. No data are bounced back. I also presses the RESET and no data are received at the Serial Monitor. But the TX pin on Atmega328 blink (I attached an LED) which shows that there are data being transmitted but no into the PC. The IC did not receive any data. (I attached an LED)

I decided to built a non-MAX232 RS232 to TTL converter (using couple of transistors, resistors and diodes). I built it based on this :
I did a looped test and data are bounced back only when battery is attached, which is a great news. Attached the RX and TX to pin 0 and 1, power up, no luck. Opened Serial monitor, pressed RESET, nothing. Upload code, same problem. I googled, found this, still no luck.

I have 3 main question and 2 sub-question:

  1. Did I fried my Atmega328? (Would the RESET test shows if the IC is working?)
  2. How can I make a test on the Atmega328? (Any more ideas to test the RX TX pin on Atmega328?)
  3. Does making the TTL converter (MAX232 / Transistor) on the same board effect the signal?

Before I turned my eyes to FTDI breakout boards, I want to try as hard as I could possibly can to discover why I can't upload codes. I'm just afraid that if I buy the FTDI breakout board, it would still not work.

I tried everything I possibly could, dunno where else to turn.
Tried every suggestion on the troubleshooting page.
No luck.

Thank you for your help.



Well, anyone ?