ATmega328 with FT232RL USB, more trouble!

So I'm using the setup described in this page: http://arduino.cc/en/Main/Standalone I am using an external 5v+ adapter.

I am a bit confused for what the vccio pin on the usb interface does. Is it an input or an output? I guess it is an input for the usb interface to know what voltage to use on the signals. In that case I should connect it to 5V+, as described in the guide. But if so, should I desolder the jumper on the usb interface board, as described in the following post? http://forum.sparkfun.com/viewtopic.php?f=15&t=21234

The guide at arduino.cc doesn't say I should...

(the guide at arduino.cc also sais: "In this situation we'll be using VCC (to supply 5V from the USB port to your board), GND, TXD, and RXD.". But that's not what's on the pictures, or in the rest of the text. Weird)

The latest schematic for the module on sparkfun shows a jumper used to select the I/O voltage to either +5vdc or +3.3vdc. Either way, it is a input pin to tell the device what voltage level to use on it's I/O pins, so needs to be wired to either +5 or +3.3 (but not both!).

http://dlnmh9ip6v2uc.cloudfront.net/datasheets/BreakoutBoards/FT232R-Breakout-v36.pdf

Lefty

Thank you :)

So as a summary: I desolder the jumper and connect 5v to the vccio pin?

SebbeK: Thank you :)

So as a summary: I desolder the jumper and connect 5v to the vccio pin?

Correct

More problems. The usb interface does not show up at all in windows xp. Nothing happens when plugged in. This is all the connections to the chip: GND to gnd on my external 5v supply. Vccio to 5v on my external supply. Vccio jumper is completly desoldered. TXD and RXD to atmel. The atmel is powered from external 5v supply.

EDIT: The usb cable was broken! Stupid. It is so often the most obvius.

More unsolved problems

picture: http://www.2shared.com/photo/zNAYjAgI/IMG_3873.html?cau2=403tNull

I'm trying to upload a simple program to the atmel. It is a uno bootloaded atmega328 from sparkfun. http://www.sparkfun.com/products/10524

The interface is the FT232RL http://www.sparkfun.com/products/718

When I reset the arduino the LED connected to D13 is blinking, so the bootload should be okay.

When i try to upload I get this:

D:\Circuit Bending & DIY\arduino-0022\hardware/tools/avr/bin/avrdude -CD:\Circuit Bending & DIY\arduino-0022\hardware/tools/avr/etc/avrdude.conf -v -v -v -v -patmega328p -cstk500v1 -P\.\COM6 -b115200 -D -Uflash:w:C:\DOCUME~1\SEBBEK~1\LOKALA~1\Temp\build4263536460026695813.tmp\Blink.cpp.hex:i

avrdude: Version 5.4-arduino, compiled on Oct 11 2007 at 19:12:32 Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/

System wide configuration file is "D:\Circuit Bending & DIY\arduino-0022\hardware/tools/avr/etc/avrdude.conf"

Using Port : \.\COM6 Using Programmer : stk500v1 Overriding Baud Rate : 115200 avrdude: ser_open(): setting dtr avrdude: Send: 0 [30] [20] avrdude: Send: 0 [30] [20] avrdude: Send: 0 [30] [20] avrdude: Recv: avrdude: stk500_getsync(): not in sync: resp=0x00 avrdude: Send: Q [51] [20] avrdude: Recv: avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

avrdude done. Thank you.

I am using windows XP.

When mesuring the TX pin on the ft232rl with the oscilloscope nothing seems to happen. It just stays static on 5V+.

Any ideas?

try this : connect reset to ground. hit upload and when you see the info about compilation being done unplug reset from ground

Amazing! It worked :D

Any way to make this happen automaticly?

Of course just find DTR pin on USB converter and connect it through 0,1 uF capacitor to reset pin :)

wow, that was amazingly simple. Thank you :) And now I'm ready to program! :D :D

hey i tried the above two steps... it's not working.... Only change is Atmega168

check if you have correctly connected RX and TX