ATMEGA328PB Bootloader problem.

Hi

I'm trying to load the bootloader onto a atmega328pb.

I'm using the bootloader program by nick gammon which i have used for many years with out a problem.

I've got the latest version of the program which is 1.38 which says it works with the atmega328pb and it detects the chip fine. When i tell it to program the bootloader it sets the fuses fine then gives me 507 error and won't program. I've tried 20 brand new atmega328pb and none of the with program.

Tried a atmega328p just to see if i was doing something wrong and it loaded the bootloader fine.

Thank you

Ben

Try burning the bootloader the normal way via the Arduino IDE:

  • File > Examples > 11.ArduinoISP
  • Upload the ArduinoISP sketch to the board you were previously using with the Gammon bootloader program
  • Install MiniCore
  • Install Arduino AVR Boards 1.6.207
  • Tools > Board > ATmega328
  • Tools > Variant > 328PB
  • Configure the other custom Tools menu selections according to your hardware
  • Tools > Programmer > Arduino as ISP
  • Tools > Burn Bootloader

Hi

I've tried using that programming method in Arduino IDE and it still don't work.

I've got some ATMEGA328P-AU and used them on ver 1.38 of the Gammon program and they won't program. Gone back to ver 1.21 and the ATMEGA328P-AU programs every time

Please do this:

  • File > Preferences > Show verbose output during: > compilation (uncheck) > upload (check) > OK
  • Tools > Burn Bootloader
  • After the process fails you’ll see a button on the right side of the orange bar “Copy error messages”. Click that button.
  • Paste the error messages in a reply here USING CODE TAGS (</> button on the toolbar).

Won’t let me upload the error messages. Says maximum 9000 characters exceeded

I’ve attached it in a TXT file

error.txt (10.2 KB)

Thanks, the attachment was the correct thing to do in this case. The 9000 character limit is a bit too small when you can't even post a full burn bootloader output directly to the forum.

For anyone else interested but doesn't feel like downloading the file, the error is:

avrdude: verifying ...
avrdude: verification error, first mismatch at byte 0x7fc1
         0xfe != 0x2f
avrdude: verification error; content mismatch

Unfortunately, I don't know what the problem is. Hopefully someone else can help.

Hi,

I am facing same problem.

I faced verification error while flashing my app hex file using ICSP (Arduino as ISP). Some posts suggested to burn bootloader.

When I try to burn bootloader the same verification error greets me :frowning:

I am using the newer Atmega328PB-U. My older Atmenga328P-AU works fine. My supply volt is 3v3.

Thanks,
WI