Atmega32u4 Failed Bootloading; SOLVED

Hi,

I created a PCB for a project and the main chip is the atmega32u4. I have tried burning the Leonardo Bootloader to it using an Arduino Uno with Arduino as isp for the programmer. The Uno has the ArduinoISP sketch uploaded to it. The error is "Yikes Invalid address of 0X00000".
I realize I have missed some components and connections on the Atmega32u4, but I have now fixed them.
The schematic:
Schematic_Ultimate Weather_2021-08-29.pdf (185.9 KB)

Any help would be greatly appreciated.

It would have been a lot easier if you would have posted the schematic in a post instead of attaching as PDF.

I notice that your SCLK is not connected in the schematic.

Hi @sterretje,

Sorry. Yes, SCK, MISO and MOSI are not attached to a pin header for programming. I have now managed to solder a 3 pin male header to those three pins for burning the bootloader. I have also added a 1µF cap from uCap to GND, and attached VBus to +5V.

Anyone have any ideas? I researched it and found that it would be from bad wiring most likely, but I already triple checked all my connections.

Woohooo! It worked! I just rewired the connections to it and it worked first try.

1 Like