ATMEGA32U4 not detected on my Mac.

I picked up "TF MicroSD Micro SD Card Slot Badusb USB Virtual Keyboard ATMEGA32U4 Module For Arduino For Leonardo R3 Bad Usb CJMCU" from a website here. It came in today, and unlike similar boards I've purchased in the past with the same chipset, when plugging it in Arduino doesn't detect any new ports. Nothing happens when not using Arduino, as well. I've tried multiple USB slots, plugging in without ARD running and plugging in after running ARD, but nothing I can do seems to make it detectable. I've also tried plugging it in with rubber ducky on a microSD card, but same problem -- or lack of problem -- nothing is detected (not even a new 'keyboard').

Anybody out there have any ideas what I'm doing wrong?

Problem solved. I had it plugged in upside down. shakes my head in disbelief

This nearly ranks up with “my computer won’t start…”… “is it plugged in”… “oh.”.

Wow. Just. Wow.

Happens all the time with these PCB USB plugs. Just glad it was not a "bad usb".