ATMEL 2560 USBASP "target doesn't answer"

I have a fresh new 2560 (this is a 2560 soldered on a PCB, NOT an Arduino Mega) with the following connections (please see schematic). I tried both using 16mhz and 8mhz crystals but when running

avrdude -c usbasp -p m2560

I get “avrdude: error: programm enable: target doesn’t answer. 1. initialization failed”

So the 2560 is not responding. I tried with several -B parameters but did not work. Am I missing something obvious? What would be the best way to proceed?

I am using the USBAsp pinout from https://s-media-cache-ak0.pinimg.com/564x/b7/11/40/b71140dd1ccb8ddf94327ab74ebe46ee.jpg

  • The connections seem ok since I am measuring 5V across other 5V,GRD pins from the ATMEL 2560 (probably doesn’t prove too much anyway)
    ** I tried this USBasp some time ago with an Arduino Mega (full board) and was working well. Haven’t tried it for some time - I think its safe to assume that the USBasp is doing well.

You’re missing a few things.
10K pullup resistor on reset.
0.1uF cap on Each VCC and AVCC pin to Gnd.
5V connected to Each VCC and AVCC pin.
GND connected to Each Gnd pin.

See everything on the left side here.

Then, use a Programmer and Burn a Bootloader to set the fuses.
After that you can use the serial port to download sketches, or use
the Programmer and File:Upload Using Programmer to load your sketch and blow
away the bootloader.

MegaDipSchR2.png

Thanks a lot, but didn't work. If that's ok, I will post a new post with the corresponding picture

Hi, I am trying to get my brand factory new mega2560 (NOT ARDUINO) chip to work with USBASP ( I uploaded a previous post describing this - ATMEL 2560 USBASP “target doesn’t answer”). I am attaching a picture. As I described previously, the USBasp seems to be working fine, as I can program an Arduino Mega 2560 fine.

It was explained to me, that I was missing quite a few connections. I corrected that (although the capacitor values I have are not the exact ones - they are reasonably close anyway). But I am still with the name problem “error: programm enable: target doesn’t answer. 1” when running avrdude -c usbasp -p m2560.

I have two doubts that might explain what’s going one: I am connecting my RESET to a 2.5K resistor ( I don’t have 10K right now) and then to Usbasp - is this correct?). My second doubt, if I measure the voltage between the oscillator leads and GRD, that’s zero. Is that expected?

Thanks

The resistor on reset goes to Vcc, not to the programmer. I can't open your pic. 2.5k is no good, you need 10k.

Why are you measuring voltage on the oscillator?

Ok, let me do what you indicated. I am re-uploading the picture, just in case. I mentioned the oscillator, because, I am not sure whether it is working.

Just tried the 10K resistor but the problem persists. Let me rephrase what I meant regarding the oscillator: the voltage between XTAL1 and GRD is 0V, the same XTAL2 and GRD is 0V. Is that expected?

http://forum.arduino.cc/index.php?topic=394092.msg2713799#new

ive got an idea, instead of putting your comments in one place why not start a new thread every 60 minutes for each sentence like youve been doing? that way you can fill up page one and nobody else will get a chance to say anything and the entire forum will come to a screeching halt.

Ricardito: Thanks a lot, but didn't work. If that's ok, I will post a new post with the corresponding picture

What? Don't start a new thread. Just add a picture to this one. Threads merged.