ATmel328p Rboard from Itead studio will not take bootloader

Foca v2.1 : FT232RL Tiny Breakout (Port 7) was verified I tried every programmer that arduino had in the drop down menu. I have an error that reads avrdude: Error: Could not find USBtiny device (0x1781/0xc9f) This is a relay board and is not typical of the unos and the others on this site. it should have the Duemilanove bootloader. I have checked the trouble shooting guide and have come up short.The device manager recognizes it and says it is working properly. I do see two quick tx and rx lights com on when I connect the USB. The power lights are on,but Nobody is home. Please help.

weldsmith: I tried every programmer that arduino had in the drop down menu.

If you are trying to burn a bootloader onto an ATmega328P you need an ISP device. Without the ISP hardware it doesn't matter which Programmer you select. If you do have an ISP device like a USBtiny or USBasp you should select that device from the list of Programmers.

I have an isp device. it is a USB Tiny, Itried that first but did not work so I tried several other things.When I plug in my Rboard to the computer the computer chimes in as if it knows its there but I still can not get it to load.

When you first plug your USBtiny programmer into the PC, does the PC see it properly as a new attachment? If not you first need to make sure you install the proper USB driver that supports that programmer before the arduino IDE will be able to find it when you select the USBtiny programmer and then select burn bootloader.


It does recognize it I can go to the device manager and I can see what port it is on (port 7). It says it recognizes it as a FT232R usb uart. the arduino IDE brings the #7 port up as an option even.

Could it be that the "Rboard" doesn't implement auto-reset? If so you'd have to do a manual reset to initiate the upload.

Select Tools->Serial Port-> port 7

Select Tools->Board->"Arduino Duemilanove w/ ATmega328"

Click on the Upload button of the sketch to be uploaded.

When the TX/RX lights flicker on the "Arduino", press the Reset button briefly. If the Rboard doesn't have RX or TX lights, press the Reset briefly when you see the "Binary sketch size:" message.

I just tried what you have suggested no good! The foca does have tx and rx LEDs. There was not an attempt to light up when I tried to load the program? wierd so I thought I would just load a blinking light program on to the board and it worked. Go figure! why would it load and not light up the RX and TX LEDs? John thanks alot for your help!