ATSAM Bootloader


I'm currently designing a board arduino-compatible which embed an ATSAM3X8E like arduino-Due, but the problem is it is said on arduino website :

The SAM3X has 512 KB (2 blocks of 256 KB) of flash memory for storing code. The bootloader is preburned in factory from Atmel and is stored in a dedicated ROM memory.

I can't obtain ATSAM bootloader, but it seems the programming port is only necessary when you want to program ( which permit maybe the compatibility but not sure)

do you have an advise to make a board arduino compatible with ATSAM?

Has anyone been working on this?

I am also stuck on the same problem.

Currently the Arduino API answer

No device found on ttyACM0

But I'm sure the ATSAM is working ( because I can program it with USB port)
And I have tried the UART communication ( With an oscilloscope) and I have seen that ATmega16u2 send data but ATSAM do not respond.
And after sending caracters throught UART communication from ATSAM to ATmega16u2, I have verify the TX pin of ATSAM so why the bootloader do not respond to the programmer?

First hit at google search for 'arduino due bootloader':

So at least the SAM-BA is always part of every SAM3X8E device.
But 'helpers' like '1200 baud' hack for erase trigger is depending on your integration of arduino standards + external components like usb rs232 bridge etc.

Sure I already found this page, but the problem is always the same, the device don't respond with the arduino programmer.

I have tried to send #V at baudrate 115200 to get the version on ATSAM but it don't respond.

Do you know a reason to don't have the respond?

Do you keep the SAM connected by native USB to your computer while trying to send the #-commands?

Or to be more precise, is it still enumerated on the native USB port -> may void trying to catch #-commands on UART.

I'm through a hub USB (not an official hub) so I'm not sure, but I will try this tomorow.

But when you try with the official Arduino Due , you don't have any problem

I have tried without the USB connection ( unsolder the 22 resistor on usb native bus) and the problem stay.

Someone have an idea about the no answer from the ATSAM?

ps: I have solder a new board, with a new ATSAM so the problem can't come from the micro controller