Attiny 85 no funciona correctamente

Hola:

Tengo un problema con el attiny 85 grabado con el arduino. El asunto que si lo grabo y lo conecto con arduino (solo tensión) funciona todo correctamente. Pero si lo suelto y conecto el circuito a una fuente de 5v (cargador del movil).Pues no hace las secuencias correctamente.

¿Que puede pasar? ¿Habra alguna interferencia con el transformador del movil? porque es conectalo a la alimentacion del arduino y funcionar como se espera.

un saludo.

Los cargadores no son fuentes, no confundir, no tienen el filtrado correcto y suelen superar la tension de 5v.
Usa una fuente o una bateria de 9v con un regulador 7805, y capacitores. Est'a teniendo un reset incorrecto.

Gracias maxid.

Pensaba que eran validos los cargadores de los moviles. Como bien dices se necesita por lo menos 2 voltios mas para que el regulador funciones correctamente, incluso 3 voltios como recomiendas. dejo un poquito de informacion sobre que capacitadores usar.

LA duda que me ha quedado es si los valores para los condensadores son universales. no he encontrado ningún sitio donde digan como calcular esos valores.

Un saludo.

PD: Feliz navidad!!!

el calculo del capacitor de filtrado depende del consumo, para un arduino com 1000uf esta bien.
El 78xx se emplean 2 capcitore electroliticos y 2 ceramicos.conectados asi.
el de 1000uf y el ceramico de 100nf en paralelo a la entrada del regulador, y uno de 100uf y 100nf en paralelo a la salida.
Esto te asegura que el regulador no se desestabilice.

maxid conoces alguna web que amplie un poco esta información?

Un saludo. muchas gracias!!

es electronica basica, en una busqueda rapida en google encuentras mucha información