attiny burn bootloader could not find tool avrdude

Hi i am trying to program this attiny 85 chip by following this link

but up to the last step when trying to burn bootloader it gives this "could not find tool avrdude from package arduino"

If the delay() is eight times longer than you expect, the problem is likely that the ATtiny is configured to use a 1 MHz clock but the program is being compiled for an 8 MHz clock. That is, either the fuses on the ATtiny weren't set (the chip defaults to a 1 MHz clock) or you did "burn bootloader" with 1 MHz internal clock selected in the boards menu. And now, 8 MHz internal clock is probably selected in the boards menu, which the compiler uses to decide how fast delay() should be. You can try either burning the bootloader with 8 MHz internal clock selected from the boards menu or compiling and uploading your sketch with 1 MHz internal clock selected (but not both, or you'll have the reverse problem of the program running 8 times too fast).

can you attempt to upload to uno (doesn't matter if you have one - if you don't, it will either give a different error, probably a sync error or port not found, depending on if you have a serial port selected, or the same error - if the same error, that means your official avr board package is screwed up)

I suspect if you were to try with my ATTinyCore instead (json link is in sig) it would work regardless of the state of the official avr board package - it pulls in it's own copy of avrdude when you install it, if you don't already have the right version installed. My core is also actively updated and supports almost every attiny part around (except the new megaavr ones, which use my megaTinyCore, and the ones not available in a version with more than 2k of flash, which I consider not worth supporting)