ATtiny85 1mhz Tone()

Can an attiny85 successfully run Tone() or TimerFreeTone() with a 1mhz clock?

I've actually been using the TimerFreeTone() library with the ATtiny85 which runs beautifully at 8mhz, but not 1mhz.

Different Attiny Cores I've used:

-arduino-tiny

-attiny by David A. Mellis

-ATTinyCore by Spence Kode

I've tried Tone() and TimerfreeTone() with all of the above mentioned cores and none of them work with a 1mhz clock.

Is it possible?

Thanks!

Please create an issue for this Issues · SpenceKonde/ATTinyCore · GitHub

Okay, and thanks for the quick response.

I can do that, but do you think it's a core issue?
Because I've tried multiple versions of multiple cores and they all seem to do the same thing(i.e. 8mhz runs great 1mhz does not).I'm beginning to wonder if it's even possible. Is a 1mhz clock too slow?

Just to link things together, here's the issue:

hoshwan:
...do you think it's a core issue?

No. It's not a core issue. Nor is it a processor clock issue.

For one of those cores in your list tone works reasonable well when the processor is running at 128 kHz.

Is a 1mhz clock too slow?

No.