Attiny85 and OLED 128x32 not displaying

Hi ... i am trying to make a simple countdown timer. i compiled it and tested it with my arduino uno and it is working just fine. i am trying to compile it with the Attiny85. it compiles with no errors but nothing is displayed on the screen. I checked the wiring several times, and tested with other codes and the wiring is correct.

i am using the "U8glib" .. .which worked for me until now, just not in the attiny85.

i tried other libraries "SSD1306" and "OLED4Tiny" but they are not working.

Please any suggestion on what i am doing wrong ? how can i get my code to work with the Attiny85.

This is my code :

#include "Countimer.h"
#include "U8glib.h"

U8GLIB_SSD1306_128X32 u8g(U8G_I2C_OPT_NONE);

Countimer tDown;

void setup()
{

  u8g.setFont(u8g_font_gdb30n);
  u8g.setColorIndex(1);  

  tDown.setCounter(0, 20, tDown.COUNT_DOWN, tDownComplete);
  tDown.setInterval(1000);


 }

void loop()
{
  
    u8g.sleepOff();
    tDown.start();
    tDown.run();
    u8g.firstPage(); 
    
    
  
    do {  
      draw();
    } while( u8g.nextPage() );
  
    delay(1000);


}


void draw(){
  u8g.setPrintPos(0, 32);
  u8g.print(tDown.getCurrentTime());    
}

void tDownComplete()
{
  u8g.sleepOn();
}

Thanks

Has the tiny got enough memory to contain the font?

yes it does, i disabled all the other fonts i dont need. and it compiles just fine. it says also there is enough memory. but nothing is shing in the display

Wiring error?

Have you been able to get anything to show on the ATtiny using example code?

I dont think that the wiring is the problem, because when i upload a different code it runs just fine.

Have you had luck with this? I have been trying to get my 128x64 OLED I2C display to work with an ATTiny using the SSD1306xLED library. The display works with the Adafruit SSD1306 library using slave address 0x3C. I tried setting that slave address in the ssd1306xled.h file but I can't get anything on the display.