Attiny85(Digispark) is not recognized after Arduino ISP

I just completed a project with Digispark. But I need to use the 5th pin which was set as "reset pin" by default. So I searched for a solution to use it a regular pin and found this Electronics Project: Digispark Overview & How To Fix Resetting - Pin 5 Reset - Digispark vs. Arduino - YouTube

Which is basically running the Arduino ISP example while Digispark is connected to Uno via couple of pins. After this process I was able to upload blink example to the Digispark just to test it. And after that Digispark is not recognized by any computer. I tried several ones but no.

If I power the board instead of connecting via USB I see that blink example runs but this is not the case with USB connection. So I suspected about pins 3 and 4 because they are for the USB connections. But nothing is connected to those pins. I even desoldered and resoldered all pins. Nothing changed.

What did I do wrong?

You tried several what? Several computers to read the same board?

Several computers to see if it is a USB connection or software issue regarding avrdude installation/setup.

Makes sense. Just needed to clarify that it was several computers and a single tiny85.

Can you please provide the code that you put on your board and pictures of your setup?

I see, yes it is the same board.

The code is here: Simple countdown algorithm for potentiometer and a button - #10 by blh64

There is no setup right now. I am just trying to upload the sketch but I cannot. The board is not connected to anything.

Usually I click upload on Arduino IDE and the IDE asks to connect the board after compile process. When I plug in the board I hear the Windows' new device detected sound and IDE uploads the sketch but after the ISP operation Windows started to stay unresponsive when I connect the board. So never uploads the sketch.

If it is because I completed the process wrongly and the board is bricked than I couldn't have uploaded the blink example just after the operation. So bricking the board or something similar doesn't make sense.

You may be dealing with a timing issue.
Try uploading the sketch with the board disconnected, then plug it in right before it switches from compile to transfer. That board has about 5 seconds of receive programming mode before it boots.
Don't know if it will work, but it's worth a shot.

Actually I am already doing it that way because the IDE gives an error if you keep the board connected to the computer. Weird actually. Just because of Arduino ISP example upload I can no longer use the board. Pity.