Attiny85 problem programming with USBasp

I tried to program my Attiny85 using this http://www.instructables.com/id/The-Idiots-Guide-to-Programming-AVRs-on-the-Chea/ instructions. I double checked the wiring, but I always get

avrdude: error: programm enable: target doesn't answer. 1 
avrdude: initialization failed, rc=-1
         Double check connections and try again, or use -F to override
         this check.

When I try to program my arduino pro mini with this USBasp all works fine. My arduino software is 1.6.5, the tiny hardware for arduino is “arduino-tiny-0150-0020”. I tried 3 attiny85. I used eigher attiny@1MHZ 8MHZ and 16MhZ.

What I can test? Do you need more info to help? See also my attachment.

greetings
Gerd

I have been using ATtiny core for 841+1634+828 and x313/x4/x5/x61/x7/x8 series Board Manager:
http://drazzy.com/package_drazzy.com_index.json

This core has worked very well for me using attiny85’s. I know I used it on IDE 1.6.5r with no problems.

Hello, I installed this boardmanager, removed my tiny-folder from hardware. But the error is the same. greetings Gerd

Hi Gerd,

Try checking your wiring again. I get the same message when I have my 6 pin ISP plug connected backwards. You can check your vcc , ground and reset with a led tied to a resistor or use a DVM. My reset reads around 4 volts using a cheap DVM. Using a led with a 220 ohm resistor I get a bright light between 5V and ground and a dimmer light between ground and reset.

You may have to get some help from one of the guys who know what they are doing.

http://dangerousprototypes.com/docs/images/2/2f/Qucik-avr-ISPconnector.png

Ken

again I used my digital voltmeter to check the wiring. Connected to USB I get 3.28 V between vcc and gnd. And I checked also MISO MOSI SCK and RESET. There is no short circuit and all wires are connected correctly. When I switch the USBasp to 5V I get 4.80 V. But both don't work.

Greetings Gerd

Do you have a pull-up resistor around 10K Ohms on the reset lead?

Do you mean like this?

sorry, the png-file is wrong. Look the jpg.

Yes!

https://www.avrprogrammers.com/images/schematics/attiny85-minimal-lg.png

Damn, this is also not working.

I also own an USB FTDI232. Maybe I can try this? But I can't find the wiring plan for this.

Greetings Gerd

"Damn, this is also not working.

I also own an USB FTDI232. Maybe I can try this? But I can't find the wiring plan for this."

Yesterday I wired up the circuit from this link and was able to load bootloader @8Mhz and then loaded a Morse code sketch I copied from the forum. As long as I left the 10K resistor in the circuit everything worked. When I pulled it out of the circuit, I got the same error message as you are getting .

https://www.avrprogrammers.com/images/schematics/attiny85-minimal-lg.png

Please try it using 5V on the usbasp. Mine doesn't work on 3.3V. If your wiring to the isp 10 pin connector matches the wiring to the Usbasp 10 pin plug I am out of ideas.

You can Google how to bit-bang an attiny85 using a FtdI232, but I think you still have something basically wrong with your wiring.

Adding a .1uF capacitor across Vcc and ground allows me to program at 3.3V as well as 5V with my Usbasp.

I had this same problem using a USBASP and the Arduino IDE to program an ATTiny85.

The solution for me was two-fold : 1) Short J3 to make the USBASP run slower (blank ATTINY85's default to 1Mhz internal clock and you have to slow down the USBASP) 2) Use Zadig to install the libusbK drivers (not the libusb drivers - these looked like they worked but gave the error in this post - the libusbK drivers worked just fine)

Just like at http://forum.arduino.cc/index.php?topic=415210.msg2862244#msg2862244