Attiny85 programmieren

Hallo,
ich versuche mich gerade in der Programmierung eines Attiny85. Die Programmierung klappt soweit super, allerdings habe ich folgendes Problem:

Wenn ich jetzt den Blink Sketch (Led an Pin 5 / Ausgang 0) hochlade, dann erlischt die LED nicht sondern im Zustand LOW glimmt sie dann noch.

Hat jemand eine Lösung für mein Problem?

Mit freundlichen Grüßen
arokh12

arokh12:
Hallo,
ich versuche mich gerade in der Programmierung eines Attiny85.
Wenn ich jetzt den Blink Sketch (Led an Pin 5 / Ausgang 0) hochlade, dann erlischt die LED nicht sondern im Zustand LOW glimmt sie dann noch.

Hat jemand eine Lösung für mein Problem?

Den wirst Du ja nicht blank auf'm Steckbrett haben...
Wo kommt das Teilchen denn her? (Link?)

my_xy_projekt:
Den wirst Du ja nicht blank auf'm Steckbrett haben...
Wo kommt das Teilchen denn her? (Link?)

das ist eine gute Frage, den habe ich schon mehrere Jahre im Schrank liegen. Hatte ich damals mal auf Ebay bestellt, allerdings hilft das ja auch nicht weiter

hier mal der Code, falls es hilfreich ist:
// the setup function runs once when you press reset or power the board
void setup() {
// initialize digital pin LED_BUILTIN as an output.
pinMode(0, OUTPUT);
}

// the loop function runs over and over again forever
void loop() {
digitalWrite(0, HIGH); // turn the LED on (HIGH is the voltage level)
delay(1000); // wait for a second
digitalWrite(0, LOW); // turn the LED off by making the voltage LOW
delay(1000); // wait for a second
}

Hallo,

womit programmierst du den? Wenn mit Arduino IDE, welches Zusatzpaket hast du installiert und wie und womit schiebst du das Programm rüber? Als Paket kann ich das hier empfehlen. GitHub - SpenceKonde/ATTinyCore: Arduino core for ATtiny 1634, 828, x313, x4, x41, x5, x61, x7 and x8

Was für einen “Bootloader” hast du drauf und welche Taktfrequenz stellst du beim Flashen ein ?

arokh12:
das ist eine gute Frage, den habe ich schon mehrere Jahre im Schrank liegen. Hatte ich damals mal auf Ebay bestellt, allerdings hilft das ja auch nicht weiter

Also wenn es kein digispark Digispark - die bequeme ATtiny85 Alternative • Wolles Elektronikkiste ist, dann mach mal nen Foto. Ober und Unterseite.

Hallo,

hätte eine erste Vermutung. Könnte mit der seriellen Zusammenhängen dessen Ruhezustandspegel. Sollte auf Pin 1 den gleichen Effekt haben. Probiere einmal Pin PB2, PB3 und PB4. Der Code selbst ist okay.

Also ich habe folgende Anleitung zum Programmieren genommen: ATtiny: Winzlinge ganz groß | heise Developer

Programmiert wird mit der Arduino IDE und dem Paket Attiny von David A Mellis.

Als Taktfrequenz wurde bis jetzt 1MHZ genommen. Wie meinst du das jetzt mit dem Bootloader?

arokh12:
.....
Als Taktfrequenz wurde bis jetzt 1MHZ genommen. Wie meinst du das jetzt mit dem Bootloader?

Wenn du 1MHz als Taktfrequenz nimmst, ist es ok, da brauchst du den Bootloader nicht. Der Bootloader ist kein echter, wird nur in der IDE so genannt. Der stellt die Fuses mit der Taktfrequenz.

my_xy_projekt:
Also wenn es kein digispark https://wolles-elektronikkiste.de/digispark-die-bequeme-attiny85-alternative ist, dann mach mal nen Foto. Ober und Unterseite.

Auf der Oberseite steht Atmen Attiny85-20pu
Wie bekomme ich denn Fotos hochgeladen?

arokh12:
Wie bekomme ich denn Fotos hochgeladen?

Unten im editor auf "attachment ,,, klicken.

arokh12:
Auf der Oberseite steht Atmen Attiny85-20pu
Wie bekomme ich denn Fotos hochgeladen?

Klicke nach der Texteingabe auf Preview und dann auf Attachments and other options.

Hast du einen Vorwiderstand an der Led ?

HotSystems:
Wenn du 1MHz als Taktfrequenz nimmst, ist es ok, da brauchst du den Bootloader nicht. Der Bootloader ist kein echter, wird nur in der IDE so genannt. Der stellt die Fuses mit der Taktfrequenz.

Ah ok, gut zu wissen.

Doc_Arduino:
Hallo,

hätte eine erste Vermutung. Könnte mit der seriellen Zusammenhängen dessen Ruhezustandspegel. Sollte auf Pin 1 den gleichen Effekt haben. Probiere einmal Pin PB2, PB3 und PB4. Der Code selbst ist okay.

Das hat leider auch nicht geholfen. Bei allen Pins ist es das selbe Problem. Wenn die LED aus sein sollte, glimmt sie weiterhin. Ja die LED hat einen Widerstand.

Hier mal ein Video:

IMG_5564.mov.zip (1.4 MB)

Was ist mit dem Led-Vorwiderstand ?

HotSystems:
Was ist mit dem Led-Vorwiderstand ?

Ja, 220 ohm

Kein Video, ein Bild reicht....und dann noch als zip....nein danke.

arokh12:
Hier mal ein Video:

MOOOOMent...
Mach das mal bitte von oben senkrecht. Als FOTO!Ich werd aus dem nicht schlau,
Das ist ein nackter Attiny. aber mit nem Konni an der LED?

Ok, da hast du recht, habe ich nicht dran gedacht.

das iPhone hat nur leider zu große Dateien gemacht.

IMG_5564.mpg (1.83 MB)

my_xy_projekt:
MOOOOMent...
Mach das mal bitte von oben senkrecht. Als FOTO!Ich werd aus dem nicht schlau,
Das ist ein nackter Attiny. aber mit nem Konni an der LED?

Der Kondensator ist in der Schaltung nicht mehr drin. Im Tutorial war er zwischen den GND und dem RESET vom Arduino UNO drin. Das ist der. Habe ihn jetzt mal entfernt, aber keine Besserung.

Da kann man es leider schlecht sehen, aber die LED glimmt auf dem Bild

IMG_5565.jpg

IMG_5565.jpg

arokh12:
Da kann man es leider schlecht sehen, aber die LED glimmt auf dem Bild

IMG_5565.jpg

Also ich erkenn darauf nichts.
Das Ding auf 300 pixel zu verkleinern ist schon nicht schick, aber der Aufbau ist daraus nicht zu ersehen.
Ich denke die LED zieht irgendwo fremd. Dazu muss aber zu sehen sein, wie das mit der Verdrahtung aussieht.