ATtiny85 /w bootloader, issue after disabling RESET pin

Hi,

I'm using a bare ATtiny85. Have been using an Uno via "Arduino as ISP" with good success. An FTDI adapter tied to TX and RX for serial output.

I need to turn the RESET pin into an IO pin and after some googling I thought I had found the correct recipe:

  1. Connect AT85 via Arduino and burn bootloader (worked)
  2. Disconnect the Arduino and upload a sketch via the FTDI (ie, serial). This seemed to work OK

At this point I felt comfortable to take the irreversible step of setting the fuses:

a) Ran avrdude to check comms OK ("avrdude -p attiny85 -b 19200 -c Arduino -P COM3 -v -C ..\etc\avrdude.conf") and that looked fine
b) Ran "avrdude -P COM3 -b 19200 -c Arduino -p attiny85 -v -C ..\etc\avrdude.conf -U lfuse:w:0xE2:m -U hfuse:w:0x5F:m -U efuse:w:0xFE:m"

All of that seemed to work OK as well

I pulled the Arduino wiring back off, just leaving the FTDI wiring, expecting to upload a sketch via serial as (I think) I tried earlier.

But no luck :slight_smile:

Reset everything, checked wiring a few times. Tried both with the reset pin pulled high via a 10k R from VCC, and a cap from DTR on the FTDI, as well as without that wiring.

I always get "programmer not responding"

The following links where helpful:
ATTinyCore Optiboot info
ATTinyCore AT85 info
Forum thread on getting the reset pin free up

Any thoughts on where I have gone wrong?

TX!
Bas

This problem occurs because you disabled the external reset pin so the programmer can't reset your chip to put into the bootloader to to flash the memory. But anyway , isp programmer also can't flash the chip.so your attiny85 is bricked. To unbrick you need a hvsp, you can use any Arduino or even usbasp as a hvsp (high voltage serial programmer).here is a appropriate tutorial

Thanks,Akash

Wow, that was an annoying video to listen to.

I much prefer Nick Gammon's write up here
High-voltage programming for AVR chips
http://www.gammon.com.au/forum/?id=12898

Hi,

Yeah, in the process of putting a HVSP together to unbrick it. So I'm misunderstanding something basic:

Bootloader code, with serial pin disabled, does not allow for code uploads?

So I need to get my code right, enable the fuse without a chip erase and I should be OK?

Bas

The bootloader is present in another part of the flash memory. Without the bootloader, when a reset occurs the mcu starts from the address 0x0000, but with the bootloader the, when a reset occurs the mcu start from the address corresponding the bootloader. The bootloader checks for any incoming data in the uart to be programmed to flash. If it finds it it will write the data to the flash

Then the bootloader makes the mcu start from the address 0x0000.but ín your case you disabled reset, so you can't program it using bootloader.

Yes, reprogramming the fuse bits will set your attiny85 on life

Bootloader code, with [reset] pin disabled, does not allow for code uploads?

Upload immediately after power-on. Oh. That might not work either, since optiboot has "fast start."
It'll help if you use a bootloader configured for a longer timeout and without fast-start. I don't know whether there's a pre-built version that does that.