Attiny85

Hi everyone,

I recently bought some Attiny 85's and I wanted to use the Arduino as an ISP to program them. To do this, I followed the instructions from this website (referred to by the Arduino website) Program an ATtiny Using an Arduino

The files and info from this link date back to 2011, so the updates brought to the Arduino IDE since might be the source of my problems:

After following all steps, when I click Upload, I get the following errors (from IDE, before uploading (while compiling)):

Blink.ino:10:21: error: Arduino.h: No such file or directory
Blink.ino: In function 'void setup()':
Blink:15: error: 'OUTPUT' was not declared in this scope
Blink:15: error: 'pinMode' was not declared in this scope
Blink.ino: In function 'void loop()':
Blink:20: error: 'HIGH' was not declared in this scope
Blink:20: error: 'digitalWrite' was not declared in this scope
Blink:21: error: 'delay' was not declared in this scope
Blink:22: error: 'LOW' was not declared in this scope
Blink.ino:10:21: error: Arduino.h: No such file or directory
Blink.ino: In function 'void setup()':
Blink:15: error: 'OUTPUT' was not declared in this scope
Blink:15: error: 'pinMode' was not declared in this scope
Blink.ino: In function 'void loop()':
Blink:20: error: 'HIGH' was not declared in this scope
Blink:20: error: 'digitalWrite' was not declared in this scope
Blink:21: error: 'delay' was not declared in this scope
Blink:22: error: 'LOW' was not declared in this scope

I tried following all the tips from an old thread talking about this http://forum.arduino.cc/index.php/topic,51709.0.html but they are not very relevant to my problem. My guess, as I said in the beginning, is that it has to do with updated IDE files or file paths for compiling. Does anyone have an idea, a guess or know what I have to do to resolve this?

Thanks in advance

I forgot to mention: I use a Mac with 10.6.8 on it and I used this option in the boards.txt file you have to create:

 attiny85at8.name=ATtiny85 @ 8 MHz  (internal oscillator; BOD disabled)

attiny85at8.upload.tool=arduino:arduinoisp

attiny85at8.upload.maximum_size=8192
attiny85at8.upload.maximum_data_size=512

# Default clock (slowly rising power; long delay to clock; 8 MHz internal)
# Int. RC Osc. 8 MHz; Start-up time PWRDWN/RESET: 6 CK/14 CK + 64 ms; [CKSEL=0010 SUT=10]; default value
# Brown-out detection disabled; [BODLEVEL=111]
# Preserve EEPROM memory through the Chip Erase cycle; [EESAVE=0]

attiny85at8.bootloader.low_fuses=0xE2
attiny85at8.bootloader.high_fuses=0xD7
attiny85at8.bootloader.extended_fuses=0xFF

attiny85at8.bootloader.path=empty
attiny85at8.bootloader.file=empty85at8.hex
attiny85at8.bootloader.tool=arduino:avrdude

attiny85at8.build.mcu=attiny85
attiny85at8.build.f_cpu=8000000L
attiny85at8.build.core=tiny

Arduino IDE version?

Which core did you download from here...
http://code.google.com/p/arduino-tiny/

I have Arduino version 1.0.5

I got the 1.5 core, I also tried with the 1.0, but same results

cyberrave:
I got the 1.5 core

There is no "1.5 core". I assume you mean "the latest version for Arduino 1.5".

I have Arduino version 1.0.5

You need "the latest version for Arduino 1.0".

I also tried with the 1.0, but same results

You are installing the core in the wrong location.

Thanks for the tips, I will try updating the arduino IDE tonight when I'm at home.

[quote author=Coding Badly link=topic=205151.msg1509921#msg1509921 date=1387243303]
Arduino IDE version?

Which core did you download from here...
Google Code Archive - Long-term storage for Google Code Project Hosting. [/quote]

You refer to cores from this link, and there is the one ending in 1.0 and the one ending in 1.5, hence the 1.0 and 1.5 core...

As for the location, i am using .../arduino/hardware/tiny/avr.

Alright,

Well now everything compiles great! but I get an error: uppon further reading, I found that I needed to put a capacitor (10uf) between the ground pin of the attiny and the reset of the arduino uno (i use R3). I also read to put a capacitor (same one) between ground and reset directly on the Arduino, but I believe that this ends up doing the exact same as the previous option)

this did not resolve the error, which is the following:

avrdude: usbdev_open(): did not find any USB device “usb”

thanks for any tips!

http://forum.arduino.cc/index.php?topic=150690.0

cyberrave:
I found that I needed to put a capacitor (10uf) between the ground pin of the attiny and the reset of the arduino uno (i use R3).

Is the ground pin of the ATtiny connected to GND on the Uno?

I also read to put a capacitor (same one) between ground and reset directly on the Arduino, but I believe that this ends up doing the exact same as the previous option)

It does. Pick one spot.

avrdude: usbdev_open(): did not find any USB device "usb"

You have the wrong programmer selected.

Thanks! it was the programmer, I had no Idea there was such an option!

It works just fine! (with a few expected errors: avrdude:
please define PAGEL and BS2 signals in the configuration file for part ATtiny85
avrdude: please define PAGEL and BS2 signals in the configuration file for part ATtiny85 )